Enqueue Scripts misbehaviour?

Hey guys,

I’m unsure about how this is intended to work but I think it at least does have some unwanted behaviour. I’m putting this in the WP section as i think it fits most. As i’m quite new to Pinegrow please forgive if i’m wrong.

So this is about the WP-Action “Enqueue Script”. I tried fiddling around with inserting my local Typekit.js today and ran into some problems. At the end I got it fixed by just calling the from the code after some hints on the chat. But what I did before was adding this action to some pages (i tried index.html, lib.html, maybe all senseless but as I didn’t know what’s right I tried some). I thought I had it removed everywhere after it worked the other way then (that -Tag insertion) until I noticed on the blog that the sites looked good (and my custom fonts from Typekit loaded) but the content was missing.

I hunted down where this comes from and found the Template-parts completely empty. Means all files generated in the template-parts/ director were there but were zero bytes in sizes. I had a blind guess that this may still come from the Enqueue-Script action that already ended in an empty index.php earlier. So I looked through all the files and found it still active in the lib.html. For Whatever reason this caused the template parts not to be generated.

Two big questions for me:

  • What did I do wrong so this Enqueue-Script-Action could completely wipe the content of the templates that were generated.
  • Why hasn’t there been any visible error for me :slight_smile:

I wouldn’t call this a bug report - maybe I just did something wrong, but then at least I would expect some kind of error message when the WordPress Export is generated.



Some system information:

  • Pinegrow 2.92
  • Mac OSX 10.11.6
  • Running natively on OSX (no VM)
  • CustoMac (i7 6700k, 32GB RAM, GTX970 4GB)

@Helmi your problem is resolved and did you get it why you got problem , and not seeing any error ?