DUPLICATE Style Ruleset not working correctly - UPDATE> Not Solved. It reverted, then sorted iteself

Hi, PG 5.991
Mac OS X 10.14.6 (WooHOO!)

following along with the Summer Nights Tutorials 2, Ive hit a bug or two.

6 mins into the video, the body class is duplicated twice via right clicking on the selected body ruleset (in blue), giving 3 body rulesets, the 2nd and 3rd being greyed out (deselected)

er, Nope!

  1. First of all, I had NO RIGHT click option. It just wasnt there. I clicked windows, docked, undocked panes, nothing worked.
    so then I had to restart PG and


I had a right click option appear.

SO then I could duplicate the body ruleset twice…but…
It didnt look/work the same for me.

The last two of the 3 identical rulesets weren’t greyed out.
as shown here

whereas in the video (different workspace layout) it looks like this.

Restarted PG> same, no difference, last two remained…er… Ungreyed out.
if thats even a word.

Or am I missing something.
But the missing right click option on body ruleset was odd too.

Finally , as a question, I understand the specificity thing and the Last rule being the winner…
BUT… shouldnt that be the LAST ruleset… as you read down?
The 3rd one? should the previous TWO be greyed out?
Or am I misunderstanding the interface? and useage?
if so, feel free to clarify.

CHeers. :slight_smile:

Hi @schpengle,
So, not sure I can figure out the problem with the inactive rules not being greyed out.

As to the order- The Styles panel of Pinegrow places the rule that is active on top, even through it comes later in the stylesheet. Fool around with duplicating rules and you will see what I mean. Off to the horses - will explain more later.

mm well Im stuck now.
I FINALLY finished the 2nd video. one hour long…took me 3 days to do and digest.
What slow learning issues?

But Now stuck as My interface aint doing what it should.

Could someone else check and see if body styles, duplicated a couple of times,on a page, show up as greyed out or appear normal?

Cheers :slight_smile:

Sorry, I thought I posted a picture earlier.

So you can see from the image that the rule at the top in the style panel is actually the last one in the cascade. In my case, the other two that are being over-ruled are crossed-out and greyed-out. I’m really not sure why yours are not.
If you add “conflicting” rules to each of the three rule sets (like I did in this example with the same property, but different values) what happens?

ok here we go… My PG.

So there ya go… 3 Body Style Rule sets… not a lot of Grey there eh?
3 different fonts,

FOUR if you count bootstrap

What the Native CSS editor shows me

Even BOOTstrap aint greyed out!

ANd now, added different background colours to the 3 duplicated BODY class rulesets.

Have I totally lost the plot, or is there something REALLY basic Ive ommited to do, like

Throw the big red lever in the top right Corner!

NO!!! NOT THE LEF>…aaaaaaaaaargh!

Something is Broked
So duplicating, changing one rule in each ruleset (BG colour) then showing. hiding and POOF!
all gone.
2 rulesets dissapear.
maybe the duplicates, Im not sure, I used different colours to identify, but now too tired, to tell,
I just want to do the tutorial!
Between this and Monaco editor debug…im sort of bogged down and getting nowhere fast.

…must try harder.

In active view, commented elements will appear only for some time to ease the flow, but will disappear at some point as this view is not the place to see comments. To see your commented items > goto the stylesheets menu and select the corresponding stylesheet.

Ok Ill check that out now.

And the 3 conflicting background colours, 2nd 2 not being greyed out , one in each ruleset, prior to show/hide?

is that normal behaviour?

I don’t reproduce this one, but what I think is that a refresh is maybe missing somewhere. What if you close then reopen the page ?

My test:

Ok! found those, cheers.
I didnt realise that.

and Ill close/open page now, try that.
ive closed/opened pinegrow, its 100% reproducible here, every time.

I just right click and duplicate body ruleset and the duplicate isnt greyed out, even before I do anything, which is not what I see in the tutorial Im following.

Ill check closing page etc now :slight_smile:

Ok, thanks.
The dev team will double check the feature and have a detailed look at your feedback.
Note: As part of their investigation, they may need more information from you and will contact you if necessary.

All good.

Right, after closing and reopening the page in PG,

I just checked the Active styles panel (thanks, I didnt realise that was its name)
And the stylesheet editor and they dont match up.

2 rulesets in active,
3 in Editor.

ok Kept PG open,
Closed page, it told me Stylesheets had unsaved changes, so saved and closed, and its opened in the same state.

2 body rulesets listed in active, 3 in editor.

Will close and open PG

done that, noted some odd behaviour.

It opens in the same state, 2 body rulesets in active css tab, 3 in editor, then
as I click the active tab ruleset buttons, it scrolls through the 3 editor versions!

waaah? :slight_smile:

and still nothing greyed out.

This is after using the DUPLICATE function, not having CREATED 3 separate body rulesets.

Ok, will leave it with you :slight_smile:
Ill have to put the tutorial on hold a bit.

just uploading a vid of the odd scrolling through classes action, will add it here now for you

Here you go.

I just tried CREATING yet another BODY css ruleset.
SO there were 3 in the active pane and this empty ruleset appeared in the Editor pane - last,

I made some changes to its contents (adjusted Grid gap with grid pane, when the NEW , body css ruleset was selected and highlit in blue BUT… the style changes were saved in one of the previous, broken BODY RULESET clone versions.

OK, thats me done on this one , good, luck let me know if. you guys need anything .


Save yourself the pain.

I had to get on with the tutorial, so Re downloaded PG,
Deleted the APP, didnt go any deeper with the uninstall,
then just re copied fresh APP to Applications

And bingo.

now i CAN …go to the Ball!
… but …but… before I go there…
Does my bum look big in this?


not solved, it appeared again.

I had the program open, custom workspace,
started tutorial,
added custom breakpoint,
resized design page view (dragged) when I noticed space on the right I didnt remember,
Clicked Custom Workspace layout to restore my workspace, just in case,


I had 3 body style rulesets, all in full colour, no 2 greyed out again.

This was the ONLY thing I did after re isntalling (well and selecting the project thumbnail to open it of course :). )

reverted to standard workspace, 3 colums, still the same.

Closed pinegrow,
re opened
body Style Ruleset appeared as it should! with 2 greyed out versions in
Default 3 col workspace.

Reverted to 2 screen custom workspace,
broken again, 3 full colour body classes.

revert to standard 3 col workspace,
still broke.
CLick on a few other elements in design view window to see different classes in active css pane,
click to tree, select body element,
Back to active styles panel,
now as it should be, … again

One full colour, active body class,
2 greyed. out.

Can you describe your custom workspace? Which windows are undocked, etc…

Yes will do,after da horsies, so a couple of hours yet.
If i sit at computer now,it will be 3.30 before i blink and screamin,late to get to horses.

Im not sure/cant see how docking/undocking/workspace layout changea could affect it,but it may be a pattern ive noticed.
But ive also been testing the monaco plugin, that broke layouts, so was checking that possibility,and since no one else on the forum corroborated thought id check it out.

Mmm,might be full images of my screen layout on th monaco editor github bug report page actually.

Right i gotta get going,doing this on phone now.

G’mornimg! :slight_smile:

Ps no monaco installed now,until i figure this out.

OK, I lied!

Here I am at the computer AND… it does seem to be that that layout breaks the Ruleset rendering correctly!
This may be why I never finished this tutorial before.

so here you go,

Started PG with standard 3 col workspace, all good.

the classes are on the right, and the last two are greyed out.
I clicked around, selected different things, used the tree, scrolled through various different class things,
opened native code editor, opened stylesheet in code editor, tried to break it, it no avail.
I guess that is good to go.

I then opened my Custom, workspace.

broken.straight away, opened with all 3 body classes displaying as normal

here it is

LEFT Monitor…Naughty PinegGrow, Bad Pinegrow! I guess it doesnt lilke my left monitor :wink:

and this is my RIGHT monitor

the display contents (pinegrow windows) are usually the other way around, but I just tried this as I realised the right monitor (the imac itself) has better resolution, larger display, so the main window works better on that…er… so I though :slight_smile:

and now here I am… at the computer…not the horses… sigh
I guess id better have lunch/eat something now then.

so, yes, changing to my custom workspace breaks the multiple ruleset display.

It’s the layout.
How mad!

I can now toggle between the workspaces

here you go,

Have a video!

100% reproducible everytime

Edit er, lets just add that link then shall we?


Ive just realised that, once back in 3 column mode, If I click on some other elements, in tree
change to active styles tab, view THIER styles…

then revert to tree, select body again…
swap to the active rules tab fo the 2nd time and…
then the 3 rulesets display correctly once more, with the 2nd 2 sets greyed. out.

and here is a vid of that.
1.Starting with custom workspace, with active styles panel infront of design view,
and broken ruleset display.
2.Switch to standard 3 col display workspace, and the duplicate ruleset display remains broken.
3.Select the navbar element from tree view, then view its styles in active styles panel
4.Swap back to tree view, select Body element, view its DUPLICATED style rulesets and LO! all is good, everything back to normal

here’s the vid of that process.

have fun with this one!

This is probably gonna be another of those minor bugs that has been there for YEARS… and no one has been dumb enough to do something weird enough to break it until now.

I did have this before and just assumed I was doing things wrong, and didnt understand and eventually gave up.
But NOW…im following a tutorial and I can SEE that it wasnt me!

Thanks for the details. I’ll try it out in just a bit to see if it repeats on my end. I’m busily trying not to procrastinate on several other tasks!