Hide Pinegrow application via keyboard (command-H) not working on my Mac

I have to go manually to the top menu to Hide Pinegrow, since using my keyboard doesn’t hide the app. macOS 10.14.6 Mojave/27" iMac. Is there a system settings change or fix for this?