Missing breadcrumbs and code tab


I have Pinegrow 6.8 installed on mac Monterey 12.5.

The breadcrumbs are missing from the bottom of the main viewing window.

The edit code tab is missing from the right hand panel. I now have to write click to edit the code.

I’ve tried changing the workspace but this doesn’t fix the problem.

Many thanks,


Screenshot 2022-09-03 at 09.40.36

Hi @timbowerbank , Im running 12.3, I have JUST fired up 6.8 for the first time.
I have the breadcrumbs on mine.

And have you tried CMD+E to brink up the code editor?

and just checked now and I too dont see the
</> tab.
So I ran back through my previous versions (ive not used PG for some time and have code amnesia!)
And… I dont see that tab now in any previous versions either.

But CMD +E brings up the full editor for me.

Thanks for your suggestion… CMD-E brings up the html for the page - what I really need is to edit the code in isolation, i.e. for a component.

The </> panel was there a while ago (e.g. 6.2 or something like that…). It’s really handy as I spend so much time in that group of panels and having to right-click or use a keyboard shortcut is far slower.

I’ve raised this before but with Pinegrow Live - Pinegrow 6.2 slow on MacOSX 10.15.7 and freezes when typing in .scss files - #32 by timbowerbank - scroll to the bottom where we are discussing ‘Pinegrow Live’.

Thanks for your input.

Cheers, Tim


I’m on Pinegrow 6.8 and Mac OS Mojave10.14.6
Mine seems to be working:
It shows the code tab at the top of the edit window, (as well as at the top of the app).
I also have the breadcrumbs showing on the left at the bottom of screen.

ok I found a way to get it back.

select an element.
select CMD+ALT+H (On Mac)

up pops your individual elements code panel, then click
Pin to Code Panel

… the …Pin icon top right of its window, funnily enough…
then it appears, fixed to the (for me) right of all the other tabs.
Then, drag the
</> icon to the position you want it between the other tabs and presto its there.
Bit of a wierdness thing, so now going to try something…

that worked!

I carried that out in PG 6.4 , closed it, then , when I opened 6.8 it was once again present in that.
So it saves that view across applications as I then lost it in 6.4 after launching 6.8.
Fixed in 6.4, was again present in 6.8.
Happy days.

SO, it also appears that if you open 6.8 and loose that code tab, then reverting previous installed versions, causes it to also be missing from that previous version too.

SO, from that, Im assuming that either the installer was saved with its current state as not having the element code view present?
Or we both had element code view missing in a previous version - for some reason…and…it continued.
Luckily I now have rememberd CMD+ H.


Id forgot that, so thats a bonus.

anyway, thats how to get it back.

your welcome… yes, I accept chocolate.

PS, humility alert.
Ive still no idea about the breadcrumbs… maybe that is a Node/Chrome/Browser views option sort of thing… in PG


Maybe this makes the difference??:
I’m using the Pro version of Pinegrow, NOT the WP version

Thank you - that’s sorted the code panel.

I’m sure the PG team will come back on the breadcrumbs.

Thanks again!


Thank you for your input too SilverT


Me gets chocolate!
Happy little dance!

PS, I just fired up PG Live too (It shows as V6.2 for me)

I also had no element code editor tab in that either, even after the above regressive fix.
I then fired up 6.8 - the lack of code tab in Live, didnt regress to the 6.8 install.

So, I did the same procedure for the Live version and now it is there too.
So this same procedure should fix your dilemma with PG Live and missing Element Code Tab too.

… *Empty dumper truck reversing up to yours for bumper chocolate harvest, right as we speak…

Not sure if i m right, but is it the same done this way:

it would appear to be so… with groovy blue circle animation to top of tab bar when activated…

Sigh… you simply must try harder… before posting bug reports…

ps, dumper truck still waiting…engine running… you dont get off that lightly…

Any news from the PG team on missing breadcrumbs? See original post above.

Thanks, Tim

1 Like

I’m sorry Tim, but I don’t face this problem or can reproduce it.

So I asked the other team members to see what they think about it and I’m waiting for their feedback :slight_smile:

Thanks Emmanuel.


@timbowerbank if restoring the workspace to one of the presets doesn’t help, please check the Dev Tools console for any red errors.