Need Help with Custom Taxonomy

Hi all,

I am still having problem getting my custom taxonomy to work. Can anyone please help?

I have a Custom Post Type called ‘projects’ and am displaying an overview of all these posts on a page. Above the displayed custom posts, I want categories to be displayed, so the user can click on one category and only see those that belong to the category.

So I want to create a custom taxonomy. I am using the ‘Post Tags & Categories’ smart action and the taxonomy is being displayed in the WP dashboard in the dropdown of my custom post type. BUT there is no field for this taxonomy when I edit (or create) a custom post type. So, I can’t assign the posts to the custom taxonomy categories.

Can anyone please help?

Be sure that the custom post type is created with the following options:

  • Public
  • Enable REST API
  • Show in menu

Then be sure to assign the new taxonomy to the corresponding Post type that you have just created.
Note: A refresh of the page can help depending on the order of the creation so you can find the Post type in the list of available items.

As for the filtering part, I’m not sure there is an easy way to do it with smart actions and adding some custom code may be necessary.

Hi @Emmanuel,

thank you for your answer. Unfortunately it didn’t fix the issue. Here are some screenshots of how I used the smart actions in Pinegrow:

And here is the issue: it does show up in the dropdown of my custom post but it does not show up in the Gutenberg Editor, where I would be able to assign my custom posts to the taxonomy categories.

Screen Shot 2020-11-12 at 8.30.29 PM

By doing this exact same process, I see my taxonomy and can use it in Gutenberg editor.
(This is the same project that I sent you through the support email)

Hi @Emmanuel,

thanks for your answer! Weird that the same process doesn’t work for me. Could it be a bug then?

Also, I just checked my emails again but can’t find a project you sent me via the support email. I only see the project I sent you. Could you maybe resend? That way I can see exactly how you set it up and maybe can figure out that way what I am doing wrong

Answer was sent again. (maybe you can check your anti-spam filter?)

@Emmanuel, are you sure you sent it to my email address? I checked and I have not gotten a new email from you (it’s also not in the spam folder).

And in the email string between the two of us from the last couple of days, you also don’t mention that you attached anything to the email. You just said that you would take a look at my project that I sent you. Maybe you can send me the project here in the forum via my account?

It would be super important for me to see how you set everything up, so I know what I did wrong

Summary of the answer:

I have created a blank project where I:

  • Register a custom post type
  • Register a dedicated taxonomy

And, on my local WP:

  • I see the taxonomy in the custom post type editor
  • I can assign a taxonomy tag
  • I can display the content of the post in a loop/custom query
  • I can display the taxonomy tags

Here is the very simple test project for Pinegrow Theme Converter so you can have a look:

Here is the copy of the emails (the original & the forwarded one):


1 Like


very weird, I do not see this in my email account. But anyway, thanks for sharing the link to download here. I got it now and will see if I find out why the taxonomy is not working for me.

Thanks again!

Hi @Emmanuel,

unfortunately the custom taxonomy is still not displaying in my custom post type editor. Even when I set it up exactly as you did it in the files you send me here.

In addition, there seems to be another thing not working and I wonder if that is a known issue and if there is a fix to it:

Basically, whenever I use the actual Image Element in Webflow, then I can’t make these editable with Pinegrow in the WP Editor. It does not matter if I use an ACF Image Field or use the Customizer Field in Pinegrow. The fields are showing up (with ACF in the Gutenberg Editor and with Customizer Field in the WP Customizer) but when I attempt to replace the image, nothing happens. The only way I can make image work is to use a div background image in Webflow but whenever I use the actual Image Element in Webflow, I can’t make it editable with Pinegrow in WordPress.

Is that a known issue?

Question: Does it work outside of your own project if you setup a test session with the project I sent you?

Hi @Emmanuel, I finally got it working! Not sure what the problem was. I started a new project and now it just worked. Maybe the old file didn’t work bc I was going back and forward. I don’t know.

Could you maybe also let me know about the Webflow Image Element issue? Is this a known issue?

1 Like