Scripts not loaded error

Hi. I’ve been building some responsive sites (which include rows/columns of image thumbnails that do responsive re-arranging with different screen sizes), and the work fine on desktops and seemingly all mobile devices.

But, I tested it on my (quite old) iTouch, and Nexus6 tablet, and found that even though MOST of the functionality works, the thumbnails are stacked vertically (nothing side by side), and are pushed to the left side of the screen. I took this as simply the browser in the devices being very old, although it was odd that the other bootstrap aspects seemed to be working.

So, for one of the first times ever, I viewed the sites on my desktop with the various Web Developer tools (in Firefox)… (I’m not a web developer, so I previously never really tinkered much with those)… and was surprised to find that despite the sites working just fine on my desktop, the developer tools were indicating that some (all?) of the Bootstrap/Javascript related files (Assets and Boostrap folders) couldn’t be loaded (404) for some reason.

I have to verify the files on my webspace today, but as far as I know, they are there… so I’m puzzled what is going on. Both of my Pinegrow-built sites are claiming this error.

All the script loading code is created by Pinegrow (as opposed to me typing it manually)… so I’m surprised there is an issue. Again, I’ll have to verify that the files are in fact there (I’m 99% sure they are, and Bootstrap/Javascript ARE working on the sites (animation is happening, etc).

Just posting here to see if this is some obvious/common error… and how to fix it.

My one site is giving me errors like:
Loading failed for the with source…, etc

My other site has a similiar error:
Source map error: Error: request failed with status 404

I’m not familiar with source maps, though.

(This is only the developer tools mentioning this… The browser itself (developer tools off) doesn’t protest or fail in any way.)

The same error seems to be occurring of all of the Assets/Bootstrap folder files.

Any thoughts?

Hi @ladlon,

In Chrome dev tools click on the settings wheel at the top right the settings panel opens, deactivate:
“enable JavaScript source maps”. They are not needed in a production site and are the result of Compiled/minified code .

It’s caused by this kind of code in your minified bootstrap.min.css bootstrap.min.js and popper.min.js and others that show up with errors in the console of the dev tools:
/*# */
It’s “commented out” so it looks grey colored.
That you can also remove.


Hi. Okay, so it’s a ‘non-error’ kind of thing… in that there’s no harm, it’s just a technicality happening (without consequence) ‘under the hood’?

Yes, but you can shut the warnings off like I explained!

Doesn’t bother me. I never see the warnings, anyway. I only noticed them the one time because I tried out the dev tools just to take a more detailed peek at the inner workings.

I was just concerned it was a ‘real’ error that I’d have to address.