Unable to type space in button text

PG version: 5.96

I’m unable to type a space character into the button field, see gif below.

I’m trying to press spacebar in my keyboard between the two words, doesn’t register for some reason, weird. This is not an issue when I type text into other components like paragraphs.

2020-07-16 10.50.12

1 Like

Tried to replicate your problem but double clicking on a button allowed me to change text OK.
have you tried clicking on </> in the top menu and editing the code itself?

yeah editing the code is not a issue… are you on the latest PG version?

Yep having this issue too. Been switching to the code to do it.

1 Like

This is an issue since PG 1.0. element interprets the Space key event as button press, so the keypress never comes to the editor. Use element code editor for such situations.

Since this has been that persistent and not able to be overcome. Perhaps adding ‘space’ into to the ‘text editing mode’ row above the element would allow people to remain directly focused as they design similar to the other options found there? Not that element code is difficult but just another suggestion.