Pinegrow Community Support Forum

Editing text in page view does not work properly for file located in subfolder

In my project, I have put some HTML files in a subfolder. When I open such a file in page view, text editing does not work correctly.

  1. On page view, I select a paragraph, ant the blue border and menu appear,
  2. I click the “Edit text” menu icon and position the insertion mark in the text (here: in front of the word “Termin”, see edit-1.png).
  3. I type “x”; the “x” does not appear in the position of the insertion mark but a few characters further left (edit-2.png).
  4. I position the insertion mark to the right of the misplaced “x” and press backspace to delete the “x”, but instead the whole paragraph text is gone.
    I press CMD-Z for undo and the text is restored twice (edit-3.png).

I’m working on Windows 7 64bit with Pinegrow 5.41 PRO Personal.

PS: I tried to attach more screenshots, but I get an error message saying “Sorry, new users can only put one image in a post.” :frowning:

You would have to show your code of the html. Make sure all the reference link to the CSS, Images, Javascript are correctly written.

Hi Terry44,
I tried to attached the HTML of the web page to this reply, but files with the .html extension are not permitted.
How should I submit the code? Should I copy/paste the whole HTML into this window??

Regards,
Detlef

You can paste HTML code and maintain the formatting by clicking the </> icon and pasting it in between the two little quote type characters (not sure what they’re called.)

Thanks for the advice, Printninja,

I did as you told me but received the error message

" Our automated spam filter, Akismet, has temporarily hidden your post in Editing text in page view does not work properly for file located in subfolder for review."

So I don’t know when the code will be available to you.

Greets
Dtlef

@dgrabowski
You can better put the page/files online on your webspace/server, and post a link to the page! :innocent:

You can access the file via

http://www.detbert.de/ws/mitglieder/aktuelles.html

Cheers,
Detlef

@dgrabowski
On your screenshot I noticed that you had activated “Test clicks”.
That could probably be the reason for your issues!

See this page, Section 3 - Test Clicks:

I’m afraid that’s not the reason for the strange behaviour. How it came that “Test clicks” is activated on the screenshot I don’t know. But I retested the behaviour and made sure that “Test clicks” is OFF. The error persists.

I can confirm the strange behavior. It seems to be related to something in your CSS stylesheet named wortschatzstyles.css. Disabling the link to this stylesheet eliminates the issue.

I experimented a bit more:

  1. Contrary to my original assumption, this behaviour is not only seen in files located in subfolders. I saw the behaviour also in index.html, which resides in the project folder.
  2. The behavior is linked to the HTML tag. Editing a

    tag works fine, editing the content of

    tags shows the described behavior. But it seems to depend on the class of the surrounding

    .

I think I got the culprit. In wortschatzstyles.scss, I disabled (commented out) the rule

p:first-letter {
font-size: 125%;
}
and editing html docs works OK.

This seems like a legit bug in PG. I’d report it.

Yes, thats what I think, too.
I’ll report a bug. Thanks for your help!

Regards
Detlef