Gutenberg blocks not showing up on front-end > SOLVED

I have created a custom theme with pinegrow and added the site content action to the page (index file). Yet, for some odd reason, the content that I add through gutenberg blocks aren’t showing up on the front-end. In fact. The div containing the site content action is completely blank. Which I think is weird. This used to work when I did it in earlier versions of Pinegrow. Am I missing something?

Please help me…


Never mind, I fixed the problem. Turns out I had to attach the loop to a container inside the content div and apply the post content action to an element inside the loop. It didn’t occur to me previously that I had to do that since I was dealing with a page and not a post… Still, it works now…

Are you creating your blocks with ACF? I saw another post where you refer to it?

@Roel, I am having similar issues as I cant get the blocks to even appear. I get this “Problem during export” message with this structure of =
-> Site Content
–> Loop:Main
—>Post Content

I am also having issues with the blocks not displaying as expected in the editor. In the tutorial it appears in the post content itself, but on my pages it appears in the right side ‘Block’ Settings, the issue is the block itself is blank

Not sure if related or what but the icons assigned and the render_template isnt creating a file as I guess I would expect.

Hey! Excuse my late reply.
I’m not sure what causes the error as I’ve haven’t had this happen yet.

In regards to the template. As far as I can see, you reference a file that is not present in the map you designated. The render_template option on the acf block registration does not create a file but looks for a file that already exists. So you’ll first have to create a file that has that particular name in the (in this case) parts folder.

Does this answer your question?