Internal server up but PG can't connect

Anybody run into this? Since I migrated to a new mac I can’t get PG to successfully start-up. Downloaded new copy, tried old version. Restarted. I’m pulling my hair out. I can point my browser at the address and get a 404, so the internal server is up. I don’t have any proxies. I tried repointing using my computer’s IP - same error. netstat reports as “UH”, so that looks good. I checked my hosts file and there isn’t any reason I can see for a block. I tried turning on my firewall and adding a rule to allow PG to connect. I have a support ticket into PG, but I was hoping somebody had experienced this previously and had a fix.


How are you doing?

Try open the “Pine Tree Poems” demo template in Pinegrow.

When you open the page on your iMac the link must be something like this:


If it doesn’t work try copy past this link to see if you get any connection. I got the same error 404 warning, but after reopening the page again it was gone.

I work most of the time in PHP with MAMP Pro so I didn’t notice it before.



well, I just tried pasting that above link in my browser and I got

404 - Not found - File /Applications/ can not be read by Pinegrow: Error: ENOENT: no such file or directory, open '/Applications/’

but if I open a page in file in PG then, hit CMD+B to open in browser, then that file will open just fine.

But… if I open the tutorials included with PG and fire up the PinePoems page, CMD+B

it opens fine! but the URL that this opens up with is (ignore the _5.93, I have different PG versions installed.)

so same port, (4000) but instead of localhost

Check port and that difference above?

And have you tried different browsers, incase it is browser specific? (my examples above work in Safari, Chrome, Firefox)
I checked in case it was some sort of security certificate/plugin weirdness.

have you tried it with Mac Firewall disabled? (and not connected to internet, of course :))

So PG support helped me to solve the problem. I’m on a Mac so, not sure if this applies to Linux or Windows.

Basically I went into ‘~/Library/Application Support’ and deleted the Pinegrow related files. I then started the PG app, re-authorized with my license code and all was good.

Thanks PG Support @Emmanuel!

1 Like

there was a similar problem then ages ago, when the CMS mode was released (which I never understood) and if you.tried it out well, that was good night Vienna! for your PG.
You couldn’t un try it :slight_smile: you had to do similar shenanigans

@RobM did you have an IP or a hostname set instead of localhost as the address of the internal web server in Settings? Perhaps that IP was not assigned to the second computer? That would explain why wiping the app data (including all settings) helped.

@matjaz, it originally gave me the error with it set to and the port at 40000. I tried port jumping, I tried setting the IP to the same as the IP of the computer I was on. Neither worked. I really think it was some kind of phantom redirect leftover from using migration assistant to change computers. Some table that wasn’t flushed that had hardware info about the last computer, maybe?