Placeholder images suddenly missing (SOLVED)

I suspect I may have done something to mess up the file path or settings somehow, but I’m now finding that some of the images (specifically the grey box placehholders, with the dimensions of the image shown on them (ex. 100x100)) are missing when I drag some of the Bootstrap blocks onto the page.

Previews look fine, but I have a broken image icon, and that image element is looking in the images folder of my current project, rather than wherever the default Bootstrap placeholder images are stored. All other images appear to be fine (backgrounds, icons, etc).

I’m not sure how to repoint Pinegrow to the proper placeholder image folder.

It appears the image it is looking for is in… but I’m not even sure where that would be (is that an online/server location, rather than a local hard drive folder?)

Hi, I’m not sure, but have you tried the "Components* tab on the top left section?
Auto reload resources on refresh,
Add/update resources etc?
Update the whole program.

check that lot out see if they help

Hello again!
Ya, it’s like I broke something! The broken image link is pointing to that odd location (http seems to imply it’s online… yet I would assume the images are somewhere in the Pinegrow program folder… but I can’t find them. There are placeholder image folders, but they are photos, and not that grey ‘800x400’ type images of the previews. All other elements are there (icons, photos, etc).
And, even though the Bootstrap block has that image pointing to that mystery placholder path, it actually goes to my OWN image folder when I click on the folder icon to redefine the path (…although, I guess it just goes to whatever the last path you went to was, despite what the path in the field is).

There’s seemingly no path settings in the Pinegrow options for me to repoint.

This ‘broken image’ thing happens even when I start a new project, reboot, etc… It’s like the bootstrap block itself got corrupted (as far as the section which holds the path to where those placeholder images are). It’s only those images, though… not specific to any block… just any block that uses those grey placeholders.

So, I would assume that folder is gone, renamed, or relocated… somehow… but I have no idea how to get it back.

Ya, as generic as it seems, maybe reinstalling Pinegrow will fix that.

I broke my brand new Pinegrow… sniff…

Well, I know that when I mess images up, pine grow ,normally warns me imags are not in the project folder, would you like to copy them to the project or such like.

I had a bit of that earlier tonight. I said yes.
but, something broke.

I think.

restarted etc didn’t quite help. so deleted and started again. worked then.
odd = probably I did something wrong.

I think what I may try, is to start a new project (…just a dummy thing), and then check out the resulting folders/files of it. I suspect that maybe there’s a folder missing in my current (real) project that will be present in the new (dummy) project.

Failing that, hopefully someone will chime in and say where those grey placeholder images are supposed to be, so I can verify their existance.

I’m notoriously talented in finding bugs in software! LIterally within minutes of running it the first time. But, I am pretty sure this is a ‘deleted/renamed/relocated’ folder type of thing…

anyway, I think those placeholders aren’t actually here I think they are an external link like to or something have a look at that
is there a link in the header to some external placeholder resource site?

if you haven’t copied that link in your header then KABOOM. all funny grey external resource images will be missing… er, thats if I’m right and thats how it is done.

and yeah I know that. the centring thing …yes… especially vertically… challenging. I have seen some good stuff on that. no link comes to mind atm<

but there was ONE vid also, posted by one of our guys that was awesome!
older version interface, but it just ran for about 10 mins or so, showing how to do the same thing different ways/techniques… in Pinegrow it was fab! I’ll see if I can find it now

1 Like

Ya, the broken image link icon is pointing at http://placehold/it/800x400

I just confirmed, those specific images ARE online… I turned on the internet connection, dragged one of the bootstrap blocks onto the page, and sure enough, the image is there now.

Okay, mystery solved. No biggie, anyway… That image gets replaced by my own image anyway.

Just wanted to be sure something didn’t get corrupted or some path got messed up.

YAY! sorry, I meant to answer it quicker, but you had quite a lot of Q’s going on :slight_smile:
Oh! ants its 2.30 am here, SO I’m a a little woozy. although excited by setting up all this new environment so buzzing a little too.
oh and I have found, I think , the vid about changing stuff in Bootstrap a zillion ways.

I’m trying to remember who posted it here originally.

Various ways to change background colour of Bootstrap Blocks is the original title.
I sucked it down from the web as it was so fab! Older interface, I think, 2.9 ish.

I’m looking for It online, If I fail, I will post it back up somehow and hope the originator doesn’t stone me to death as it was masterful!

No need to apologize! :smile: I didn’t mean it that way at all. This has been a really great talk. It’s great to chat with someone helpful and pleasant.

Check out the Web Ninja tutorials on YouTube… Really helpful to me (but, as I mentioned, be aware of which ones are Bootstrap3 vs Bootstrap4).

yes might have a look. mmm I will upload this vid to Youtube now.
I will warn you. you will be doing a LOT of pausing and rewinding :slight_smile:
and he is JUST changing bootstrap blocks background colors.

for about 9 minutes!

Bring it!! I’m a sponge, eager for knowledge! :grinning:

its being a …pain. uploaded, not playing ball. hang on

Its been stuck at
91% processed. About 10 seconds remaining. for ages