Psedo States. Not showing in the panel

So I have created a hover state for a second class on an element but I don’t find it in the style panel when selecting the : hover button?
I just find it if I go under tab style.css next to active.
Should not I see it there just by clicking the pseudo pg button?
Many Thanks

you need a .btn-arrow:hover rule for the hover feature to show it to you in the active styles tab (and you need to have the btn-hover element selected in the tree, as you know).

Yes I know that, but my pseudo-class is applied to .about-us-btn:hover .btn-arrow {
margin-left: 1.5rem;


i’ve also found that using combinators seems to break that feature in PG, and i notice you have the descendant selector there on that rule.

That’s right. I am using the descendant combinator here but Pinegrow seems not to know what/how to do with it.

since i’m now running 5.8pro and just verified this behavior was not one of the CSS “bug fixes”… then, it should submitted as a feature request.

Just changed the status to Bug Reports.
Let’s see.

1 Like

how did you do that?

i’m trying to change an earlier post to Feature Request, and it seems like i just need to start from scratch, even tho i would like to link the request to my earlier thread.

btw, i don’t think its a bug… it’s a “feature” or lack there of.

if you are logged in, besides your post title there is a little pen indicating edit function. Click on there and you can change the category it belongs to.
Anyway, I will leave it as a bug report. If dev team says it’s not a bug then i will move it to feature request.

the category options were only the original “beginners” cat, and adding additional ones (on the right) does not seem to cross post to the other category

i created a new post so we cover the problem from both angles.

it really needs to get fixed to make the ACTIVE tab fully useful… it’s almost there.

and save.
Anyway, i just saw your post. good!