Saving Bug, does not save and reverts to default

Hello I am having a lot of trouble getting my work to save properly. I am using bootstrap blocks in pinegrow (and just about everything as well) and every time I go to re-open the html file in either the browser or in pinegrow, it reverts back to the template block with only the text and links intact.

So any work I’ve spent hours on, gone. I’ve even tried disabling “save back up files” and “auto reload files” but still my work does not save properly.

Any help would be appreciated.

Hi flexbox,

Could you provide a little more information. Pinegrow displays your work as it should in the browser. If you are trying to view it in a browser and loosing the layout then something is getting lost somewhere but it may not be pinegrow. Are you using the standard blocks in pinegrow" “Bootstrap Blocks” template or your own?

Also maybe upload a video showing the site before and after you press save, may help us spot the problem.

Sorry for the late reply. It decided it wants to work now and I don’t have any more saving issues. I am using bootstrap blocks. Now I have another ridiculous issue this time.

I’ve been having this issue a lot lately where I am using bootstrap block’s navbar and every now and then, randomly it will stop using the collapse function on the smaller resolution. Also the default scrolling gets messed up where if you scroll down it eases out, then scrolling up it appears but not it’s just fixed to screen.

Keep in mind I don’t touch any scripts and I’ve never altered any of the navbar’s CSS apart from the coloring or padding. This is happening in both “test clicks” and after I’ve saved the html/files to run it in my browser.

@flexbox360 is it possible to upload a video or screenshot because I’ve used the bootstrap block navbars in the past and never run into any issues.

Is it header 1 or 2?

It’s header 1 video:

I found if I leave it for a few hours, it begins to work fine again. But when I start working on any part of my page it just stops. I’m guessing it’s the scripting (again, I never touch it). It’s the only thing that gives me a problem, I even tried copying over the bootstrap scripts from a new nav in a blank bootstrap blocks page. Worked briefly but then it stop again.

@flexbox360 that looks like you have a conflict within your project, have you loaded any external scripts? javascript files?

I’ve had an issue in the past with the standard Bootstrap nav not collapsing due to a conflict, however as you’re saying its working at random times, that sounds like odd behaviour!

You could copy the entire project folder, open the copied folder and section by section start deleting sections and testing the navbar, while also I would need to see exactly what scripts are loaded in the header and bottom of the page, because without seeing your project in full, its difficult to see exactly what’s going on.

I did add in an extra line of script without altering the default scripts but that was a while ago and it was working fine.

However I have the solution of just copying the script files from a fresh project into my existing one, then the problem is solved. So yeah, I do believe there is something going on in my project that is clashing.

If I do figure out the exact cause, I’ll be sure to report it here so others who may have a similar problem can find it. Thanks for the help.