Pinegrow Community Support Forum

Bug - Pinegrow Project view not Showing new directories created with *Manage Stylesheets* tool

#1

As described here

then if I Restart Pinegrow
It appears, as expected, as shown in this image.

2019-02-21_19-32-08

ok and updating this… Or maybe even a new bug… I can no longer tell…

if I do the same as the chap with a problem in the Slack channel, here

https://pinegrow-webeditor.slack.com/archives/C075YQB5F/p1550165925019300

it doesn’t work for me either.
I dont understand the reply that says about resources not being loaded as I thought they were, due to the script tags at the bottom of the code…

however…I can’t get it to work either.

and what is more it doenst seem to reload the project view with the Bootstrap resources either,
and

After giving up on this and creating a plain html file
saving it in a new directory
activating bs 4 via manage libraries and classes
adding resources via local files

it still doenst work…adn the tree view shows the resource scripts added at the end
but the code view doenst change.

I have been on this all day…

so after activation and adding I see this… still not bootstrap in the code.

so reload project…

the resource loading scripts appear in the tree but STILL not in the code…
and the drop down still doesn’t work.

#2

aaaand

it would appear that the Bootstrap 4 Navbar drop down menu item doenst work correctly / at all in Pinegrow

but this dropdown from the following one does

https://www.w3schools.com/bootstrap4/bootstrap_navbar.asp

Care of me ,and @Marf,
your caring cartoon characters

#3

@schpengle We talked about this yesterday (on Slack).
Like we spoke, I didn’t experienced the problem with the resources added to the page and project folder. That worked fine for me.

But I do experienced the problem that the dropdown is not working (for BS 4).
I tested it with you with Bootstrap 3, that worked fine like expected.
And with Bootstrap 4, which did not worked like it should be with collapsing the dropdown properly.

You mention that example from w3schools, maybe better look at the one from the bootstrap site (the second one I shared with you yesterday), which is more similar to the one Pinegrow provides.

Bootstrap Site (first code example)

I shall see if I have some time later today to have a look and compare those 2 pieces of code, the one Pinegrow provides and the example from the Bootstrap site, and see what is different between them and why the one from Pinegrow is not working like it should.

1 Like
#4

The issue with navbar dropdown in Bootstrap 4.2x is identified.
Read more: https://github.com/twbs/bootstrap/issues/27903

It will be fixed with the release of the next version of Pinegrow (which will include Bootstrap 4.3.x)

#5

OH thank you! this is great bug hunting on your part!
Cheers @earnoud, I would not have thought of actually checking out the Bootstrap code itself.
and from the solutions I have seen there, I doubt I would have been able to work it out either.

Thanks. I am just going through that now and will post the code fix from there to here now

#6

Ok!

Well, first I just learnt that Currently, Bootstrap DOESN’T support Multi level dropdown!
Only 1 Level!

Well, I never knew that!
here is the Link on that info

Then. I find that one of their team, has created a working version!
with multilevel dropdown.

here it is on CodePen

Where it works.

But I can’t get this to work in Pinegrow, and when trying , hit a bug.
I checked in codeine and the cdn it uses for this for css was 4.21.
I was going to use the same external cdn resources, but hit a snag.

#7

Ok! it works!

A multi level drop down navigation in Bootstrap 4.21