Suppress popup warning - "Can not edit this element" (Mathjax)

I have many instances like the following that contain Mathjax formatting or equations –

<p>Text ... \( Some text here \) ... rest of paragraph or tag.</p>

“(” denotes the beginning of Mathjax and “)” denotes the end of Mathjax. These can occur anywhere within the paragraph.

Whenever I double-click on such an instance in order to edit, a popup always occurs –

I always choose “Edit anyway”.

Is there a way to suppress this popup?

Don C.

Hi @dculp,
Can you try with JavaScript turned off - the JS in a square icon in the top bar clicked so it isn’t green? Not sure if this will severely break the look of your page.

RobM –

JavaScript is used to render Mathjax so turning JavaScript off wouldn’t be an option.

With JavaScript rendering Mathjax –

Without JavaScript rendering Mathjax –

When you are editing it, don’t you type what is shown in the second example with JS turned off? Can you now edit that element? What happens in Pinegrow when you click on the “Edit anyway”?

RobM –

To edit the second example, I would do it in the code editor where its formatting is easier to understand –

<p class="_eqn_latex notranslate">
\begin{align} \label{eq:12401a}
c_{tw} &=
\left[ \frac{E}{\rho} \right]^{1/2} \,

Many equations are much more complex and almost require the code editor. I can live with that.

I should modify my previous reply (“turning JavaScript off wouldn’t be an option.”). Turning JavaScript off is possible but somewhat degrades the utility of the WYSIWYG editor. For example, the following WYSIWYG paragraph –

without JavaScript appears as –

While this is not unacceptable, I was hoping that there might simply be a switch to turn off this (somewhat annoying) popup without having any other effect on the WYSIWYG editor.

(If I choose “Edit anyway” then the edited paragraph appears as in the last image above (apparently with JavaScript turned off for that paragraph). However, the remainder of the page remains in WYSIWYG form.)