Unable to customize bootstrap theme

Hi all,

This is my first post as a new user of Pinegrow, so maybe my question is very obvious and has been already answered many times.

I want to use a customized version of Bootstrap and I am following the instructions on the video “How to easily customize Bootstrap 4 with Pinegrow Web Editor” but it is not working for me.

I am using the latest 5.992 version and I duplicate the actions on the Video.

  • File | New page
  • Bootstrap 4 | Select the pricing template.
  • Save
  • Page | Customize & update Bootstrap Theme | Sure, let’s do it

At this point I get a modal that says:

Local bootstrap.css was not found on the page

Couldn’t detect a local Bootstrap 4 stylesheet on the page.
Customizing the Bootstrap theme doesn’t work if bootstrap.css is included remotly, from a CDN.
To proceed, include a local copy of bootstrap.css to your page and repeat the Customize Bootstrap Theme command.

But the previous procedure created the following link on the header section:

link href=“bootstrap/css/bootstrap.css” rel="stylesheet

What can be wrong?

Thank you very much in advance.


Hi @Manuel,
Sorry to hear you are having problems. From the info you have given, I am puzzled by the error. Quiting Pinegrow and restarting might get rid of the problem. If not, can you do two things for me?

  1. Send me a screenshot of your Project panel. That is the one located on the left side of the App with the folder icon tab.
  2. Send me a screenshot of the “Manage stylesheets” modal. It is opened by going to the File menu and selecting “Manage stylesheets”. It should look like this.

    I’m wondering if it is some problem with permissions or hard drive space?

Hi Bob,

It is very strange indeed. I have not only quit and restart, but also installed the previous version to see if the problem disappeared.

Anyway, here are the screenshots:

Hope they help.




I have tried again, this time using the empty HTML template and the beta of Bootstrap 5 and this time it has worked!!!

Go figure.

Anyway, thank you very much for your interest.


Hi @Manuel,
Still very strange since it seems like the Bootstrap_theme folder never got created along with the custom.scss file. Glad it is working with 5. Shout if you want more help.