Code formatting

Hello, how can I set that the formatting of the code is saved correctly, I have wrapped code in several lines, press save, when I open the file again it is again a 1 line?

Pinegrow does some automatic formatting by default. You can go into the settings and uncheck the box that controls whether to auto format or not.