Custom Post Type Classic WP Editor

Hello, I apologise for having another issue here. I reckon the lads have grown tired of my posts :face_with_diagonal_mouth:

I don’t know if its on my end or not. The issue is with custom post types. Specifically the Wordpress function Register Post Type within Pinegrow. I was following one of Adam’s tutorials on Youtube till I ran into this issue. My custom post type is named ‘Menu’s’. I appears on the menu bar as it should but the only issue is that once I click on ‘New Menu’ the next page is in the classic Gutenberg editor. Not the new version. I am running 6.1. I hardcode a custom post type and I have the latest Gutenberg editor with no issues. What am I missing here? I see in functions.php rest_api => true. I obviously have the box ticked as you can see in the screenshot. Is there a method to connect a current custom post type I have coded myself to content in Pinegrow or is it best I hardcode it?

Hi there.
Out of my depth here but have you tried it with
Instead of Menu s?

I’m not sure (ie, have no idea) if that will make a difference but I did notice Adam posting about Gutenberg blocks haveing issues with


…yes, for something else, but maybe a quick check?

…while you’re waiting for a competent adult to show up…

@schpengle Did you just tag me in a post and say something about a “competent adult?” c’mon… you should know better!

The only thing you are missing is to tell it to support the editor. Without that, you get the old classic-style page.

1 Like

Well… worth a try weren’t it? :smiley:
And… if that little clicky tickbox type additon is all she needs… jobs a good un.

SO, I MIGHT…just have got the wrong reason,
I PROBABLY… got the right person…involved :smiley:

not sure about the adult bit though either :wink:

hee hee hee… the end justifies the means.

Probably … the best…


Hi @schpengle I did try that myself but no luck.Thank you though. Are you on the drink sir? lol :grinning:

adamslowe thank you for your lovely videos I’ve learnt very much from them indeed. I was driving home from work through mad Irish mountain roads and it did occur to me I may need to add a specific field. And that was the remedy, once I added the ‘Editor’ field I finally had the new Gutenberg editor. Your a proper gent, many thanks for your wisdom. I feel like a bit of an eejit for not trying that myself :neutral_face:

1 Like

Job done!
and yes! Mint tea!
The Mother of all Thermos flasks full of it here… gonna be a long night of visits to the little house on the prairie I think.
And hows the Emerald Isle for snow atm?

We have the sneachta in higher elevations like were I live. Mint tea I don’t believe you so I don’t :joy:

1 Like

Hic… tis Lies
Well, not too high here, (South Wales) but snow around my horsies feestses.

Welsh… the Irish who Couldn’t swim

1 Like