Pinegrow Community Support Forum

Does PG v5.7 Support Atom?

I cannot get Atom to recognize or link with PG v5.7 on my Mac - I get the error shown in my screen capture below that indicates it’s trying to use port 40001 but PG’s Show API URL says: “http://localhost:4000”. What am I doing wrong? … Is it still supported?

As far as I know, Atom and Visual Studio both integrate well into PG.

Not sure what point you’re trying to make. Taking one of my old posts out of context?

I think your post applies, but per your wishes I have removed it. Far as I know nothing has changed and Atom and Visual Studio can still both be integrated.

I am on a PC and use Visual Studio, so in the next hour or so I will give it a go and see what I come up with.

By then someone else, or even you might respond with a solution. Personally, I would try different port configurations and make sure that nothing is blocking anything.

This includes firewalls and antivirus software.

https://pinegrow.com/pinegrow-atom.html

In Atom use Packages -> Pinegrow -> Detect PG <-> Atom file path mapping to auto-detect the correct path mapping.

OP, I might have some bad news, which might be what was being alluded to…

I don’t know if there ever was a fix yet and I am still looking.

The error you are having is described perfectly here:

Last updated on November 9, 2018 at 6:12 am.

OP, I hope this helps… This is the latest I can find:

https://pinegrow.com/docs/master-pinegrow/using-external-code-editors/

The “API URL” must be configured the same at both ends, inside Atom and Pinegrow Editor.
Make sure you setup and use the same port. That should probably solve the connection issue!


3. Configure API url

In Atom go to pinegrow-atom settings and set the URL of the Pinegrow instance you wish to connect to. Note that every Pinegrow window has a separate API URL. Use Support -> Show API url in Pinegrow to get the correct address.


@randyrie

I was unable to load Atom (had a procedure entry point problem [that I really didn’t care to resolve]).

What I do have (without any hoopla I might add) is a direct link between Visual Studio Code AND Pinegrow PRO.

I installed the plugin, didn’t have to do any restart, and I didn’t do any configuration setup. It all worked as they say, “right out of the box”.

After installing the Pinegrow Live Sync 0.0.5 plugin I opened Pine Tree Poems demo in PG Pro and I opened the same folder in VS Code.

I then clicked on ‘pinepoems.html’ in VS Code and up it came in the HTML editor. I have PG Pro on one monitor and VS Code on another.

Any changes I make show up instantly on the other monitor in the other program. If you can’t get Atom to work, then I definitely think that you should give VS Code a try.

There are plugins for VS Code to make your experience more Atom-like if that’s what you’d like.

Happy coding!

Thanks for the tip @Pervasive
Do you have the URL where I can get the current PG <-> VSC plugin?

Inside Visual Studio Code do the following:

…and be sure to have autosave turned off in VS-Code or you will get a distructive loop that will scramble your code.

@randyrie
FYI, I experience no problem with the Atom Plugin, it works like expected for me with Pinegrow v5.7 (on Windows 10), and they are connected. It could be a Mac related issue.


Is the problem still present after “closing and restarting” both apps (or a system restart)…??

I’m having this issue on both my Macbook and my iMac so I am beginning to believe it is a Mac issue… the PG CSS editor has been acting flaky on both machines since I upgraded to v5.7. I’ll wait until I hear back from Pinegrow Tech Support before I start my panic attack. I wish I was an expert with CSS so I could self trouble-shoot this…

I still can’t get VSC to communicate with PG so same question as earlier… PG reports its API URL as: “http://localhost:4000” and VSC notes that it uses the PG URL “+1” which should make its connecting URL: "http://localhost:40000 but VSC reports it can’t find PG on port 40001 - - very confusing. What are your PG and VSC API URL settings?

i’ve tried both now and atom seems to more tightlyt integrate with PG.

VS has a LOT of bells and whistles that seem to get in the way more than they help.

and for somereason it would not show changes on the PG screen until i saved the VS copy of the document, which is an annyonying extra step.

i must say i’m a little disapointed that neither editor actually REPLACED the </> editor in PG… which is what i expected.

is there any way to have either edtior stay on top so it can be used like the builtin one?

@randyrie

The default port that Pinegrow uses is 40000 (4 zeros), that’s exactly what is described.
40000 (4 zeros) +1 = 40001 !!!

You now have configured in Pinegrow 4000 (3 zeros).
Change this to 40000 (4 zeros), “pinegrow > support > settings”.

And of course also use 40000 (4 zeros), inside Atom and Visual Studio Code.
Then it should all work fine! :wink:

1 Like

What Marf said, 100%! For any communication to happen you must use the same port on both ends.

Ports can be synchronous or asynchronous (goog is your friend [not really])… if one program transmits on port 40000 then the other program will have to listen on port 40000 – sort of like the old switch board operators to patch through a phone call.

Http is port 80, https port 443, ftp port 21, sftp port 22, and the list goes on. There’s even such a security thing as port knocking, like entering a code on a schmantz car to go through the door.

I don’t have any more information than you will find if you followed the link I sent you earlier!

Please have a second look at the following link: https://pinegrow.com/docs/master-pinegrow/using-external-code-editors/

Yep. That worked and I now have VSC working perfectly in sync with PG. Thanks for your help @Marf!!

i’ve settled on using VSC rather than Atom because i can get the color previews to appear in the code much like they do in the styles editor inside of PG.

trying to get Atom to do this was just painfull and the results were laggy and slow.

just make sure to turn off the telemetry in VSC, microsoft doesn’t need to know what you are doing.

2 Likes

huh? uh-no! not more corporate spy-devils…

They bought linked-in, nokia, github, not to mention what’s built into windows 10… and all the companies like them, why there’s no end in sight.

I costs too much money to try and keep them in check. What makes it even harder, is that they have all the money. :scream::money_mouth_face::sweat_smile::confused::smirk:

Thanks @droidgoo, much appreciated!