Is it possible to run the pinegrow internal webserver via HTTPS?

Having an iframe content I can’t show because the iframe origin needs https://localhost to work. I can change the IP to “localhost” which is great, but it’s still only http:// so the iframe won’t load.

Thanks for a great product!

Well, in the time honoured WWW tradition of asking a simple question … and getting people say Well, why are you doing it that way? why dont you… etc etc

I offer this solution to your conundrum!

Its what I had to do do… so long ago, its not really worth asking me for any advice, as I’ve forgotten it all, but that was the workaround I employed.

That link is much more up to date than what I used and is rather a good long content read.
I’m not reading that!

But they are usually pretty clued up folks.

let me know how it goes if you go down that route :slight_smile:

EDIT… mmm as I think about iIt, it might also well be that I WASN"T using PG’s internal web server with this…for this reason… but rather. some other.
Native Mac Apache…AAMPS>. MAMPT etc.

In which case I THINK I would have had to have added my self certification to the server…somewhere…

SO, not sure how much my not what I asked for answer would be.

BUt I suppose if PG implemented that self certificating thing… or made scope for it to be added to tits server (no idea how) I guess you could then rock it out that way.

Im not terrible (at all) web active at the moment… so some of this this may be redundant…in hindsight…

SO I shall now depart.

No INK was harmed during the production of this comment.

1 Like

That’s some nice info, but I already have an external testing environment where I can solve that. This question was specifically for the local dev environment.

I can see the iframe contents when I first insert the URL, but efter a reload or looking in a browser it blocks it.

As a workaround, I have saved the iframe to a local HTML doc so I can see how it looks, but I can’t interact with it for real. Simply have to replace the URL when publishing.

I will also try and change the source to also accept HTTP. But its a login from Azure AD so…

But thanks for the feedback.

1 Like

I confirm that it is currently not possible to run Pinegrow’s internal web server in secure / HTTPS mode.
The use of an external web server properly configured remains the only solution for this type of need.

Thanks for the confirmation.

Will rely on an external dev server for that part then.

ok, just clarifying, that whole self certification thing was for local web dev. but i was also employing a local webserver other than PG’s built in one, in order to be able to view local https links. I then remembered, on the MAC I had to approve adding the LOCAL self certifying authority (my own certificate) to my Mac’s keychain.

so that was all to enable local dev and local web browser access locally hosted sites of the https variety.

just clarifying that bit for you and , good luck :slight_smile:

Wanting to view the browser preview in my actual smartphone. I think it’s connected to this. I’ve been trying to type the URL in my smartphone but don’t have a connection in webserver. So, up for this

It’s not connected to this.
But a valid request. You should start a separate thread for that if you want that to happen.