Pinegrow Community Support Forum

Local WebDev Environment -Anyone heard of/used/using AMPPS?

#1

Hi all, I was just checking my downloads out and came across this that I never seemed to have installed.

http://www.ampps.com/

it looks rather handy! its from

http://www.softaculous.com who also make

http://www.softaculous.com/softaculous/ which integrates with it and offers 55 different one click installers in their free version - and 441 in the paid version.

awesome

and compare as shown here
https://www.softaculous.com/softaculous/compare

and have an active support forum!
https://www.softaculous.com/board/index.php?fid=12&fname=General_Support

SO, if you want to try it out, as I did -well it didnt work at first.
when i installed it, (on mac os x- 10.6.8) it fired up , nice little control panel on the right but… blank home and admin page! gah!

after some hunting around I found this

https://www.ampps.com/wiki/Enduser_Panel_gives_a_Blank_Page

which says

Enduser Panel gives a Blank Page

If you are getting Blank page while accessing localhost/ampps

Its because Your php version isn’t loaded.

Ok then, so lets sort it!

Open AMPPS Control Panel and Restore Default Configuration of PHP. Then follow the below steps.
Cron was not able to run after installing AMPPS for the first time.
For Windows, type this command in command prompt
“path\to\Ampps\php\php.exe” -c “path\to\Ampps\apache\php.ini” “path\to\Ampps\ampps\softaculous\enduser\install.php”
For Mac OS X, type this command in Terminal
“/Applications/AMPPS/php/bin/php” -c “/Applications/AMPPS/php/etc/php.ini” “/Applications/AMPPS/ampps/softaculous/enduser/install.php”
Restart Apache.
(Note: Please make sure your Internet Connection is working properly)
as no such file or directory

gah! so opned and inspected the AMPPS app package and, its not there. but there is php-5.6 and php-7.1

pretty random bug. maybe I should let them know :slight_smile:

so, I ammended that so that each AMPPS/php/ became AMPPS/php-5.6/ (there is also 7.1 installed)

AND BEHOLD THE SHINY GOODNESS THAT IS THE AMPPS ENVIRONMENT! mwaa haaa haaa

SO, I usually Use MAMP (Pro)
and am rather happy with it (apart from the crazy permission/user account swapping game I have to do for each wordpress install - I am obviously doing something wrong there)

But this is FREE!
and seems to do a WAY Of a lot more things. Not sure if it runs when offline though.

But, it might be handy to explore for someone else too.
ok, long late post. I might fire this up on High sierra too, see how it trundles.

PS>
I’m also exploring

Prepros ( I think something along the lines of CODEkit for mac)
and some other text editors.
this vid shows a nice intro (a little slow but good for beginners)

VVV… and VV - Variabe Vagrant local environment for mimicking any servers, or setups you have to work on

https://webdevstudios.com/2015/01/14/getting-started-vagrant-vvv-local-development/

and, its set up to not get destroyed by GOOGLE now owning the .dev TLD.

this All looks rather interesting.

1 Like
#2

Woah!

without a doubt, the easiest Wordpress install I have ever done.

http://ampps.com/wiki/How_To_Use_Scripts_on_Local_Network

well, and maybe Flywheel by Local too, but that is a pretty HUGE install.

#3

Quick update, Just installed this on High Sierra,
launched with NO PROBLEM.

no faffing about.
Excellent. Oddly enough it installs with a premium licence whose expiry date is never
maybe this is the build to get :wink:

#4

UPDATE

well, this has been a pain! it has not worked correctly for AGES!

I have JUST got it working again after months, re downloading MAMP Pro and was about to give up and INSTALL it.
but it turns out, that … the command line fix they say, works (and doesn’t)
DOES work… eventually, if you tweak it, BUT it has issues

It all comes down to getting install.php to run… correctly, post install, to fix it.
Now THIS was the problem.
for me this could not run correctly, and then, it deletes itself! I had a firewall issue which I couldn’t track down.

so after months of a BLANK home Page and Admin panel and repeating the whole thing over and over again,
It turns out that my problem was

  1. ALWAYS HAVE A (direct, not proxy) INTERNET CONNECTION WHEN INSTALLING AMPPS-
    In the FIRST PLACE! if you install it when offline.your screwed.

    This is because it downloads files… the install.php does that, during install.
    now a problem is here. IF it is blocked by, say your firewall, (me) or something, then AFTER IT RUNS

So, if you have a blank home/admin screen you are supposed to run this MODIFIED FOR MY SYSTEM

“/Applications/AMPPS/php-5.6/bin/php” -c “/Applications/AMPPS/php-5.6/etc/php.ini” “/Applications/AMPPS/ampps/softaculous/enduser/install.php”

and bingo it is supposed to work.
unless, it is blocked by your firewall, then… it deletes itself!


(from
https://www.softaculous.com/board/index.php?tid=4650&title=Blank_page_while_accessing_localhost/ampps_and_localhost/ampps-admin_(under_OS_X_Mavericks))

yes! that is right, it DELETES ITSELF> GAH!!

so it is gone. if it didnt work, then your screwed because its NOT there anymore, so you then get the

no such file or directory in terminal, runaround.

not much fun, and you cant run it …again, because you have lost it.
so , if you see that, you have to get install.php and run it again.
but HOW?

Well, apparently you are supposed to run the CRON job file, in order to re download it.
but again, you ALSO have to edit the command that is shown on web sites as a solution to the correct php version.
ie, for me this command is…

“/Applications/AMPPS/php-5.6/bin/php” -c “/Applications/AMPPS/php-5.6/etc/php.ini” “/Applications/AMPPS/ampps/softaculous/cron.php”

Again, you must have a WORKING INTERNET connection AND NOT HAVE (like me) Some firewall rule, blocking it.

(what showed me I had a firewall issue was THIS message returned in my terminal

Warning: file_get_contents(http://api.softaculous.com/ip.php): failed to open stream: php_network_getaddresses: getaddrinfo failed: nodename nor servname provided, or not known in /Applications/AMPPS/ampps/softaculous/enduser/install.php on line 6
)

Also, another way is to download the whole AMPPS installer again… and just copy the the install.php file from the installer, located at

/AMPPS/ampps/softaculous/enduser
from the installer to the same directory of your installed app.
A little excessive - but I did this too.

finally, after realising that I was going in rings, running then losing install.php , I did this

  1. Kill Firewall (sad but true)

  2. re download install .php via this command
    “/Applications/AMPPS/php-5.6/bin/php” -c “/Applications/AMPPS/php-5.6/etc/php.ini” “/Applications/AMPPS/ampps/softaculous/cron.php”

  3. RUN install.php via this command
    “/Applications/AMPPS/php-5.6/bin/php” -c “/Applications/AMPPS/php-5.6/etc/php.ini” “/Applications/AMPPS/ampps/softaculous/enduser/install.php”

re implement firewall.
Bingo.

also, just to be safe I turned off auto detect proxies in my Macs, network settings as, apparently, AMPPS cant do this over a proxy connection.

Bino it all works again.

N.B.
this version looked much simpler… IF you have install.php in the correct place, not dissapered.
https://www.softaculous.com/board/index.php?tid=4140

:slight_smile: -maybe for next time :slight_smile:

I am now nervously watching the ioncube loader link, just in case…
https://www.softaculous.com/board/index.php?tid=13497&title=Ioncube_Loader_Error

SO I am updating this thread with this fix as the simple version posted at
here


didnt work

Which is basically
*Hi,

1.Select PHP-5.3.

Open AMPPS control panel --> PHP --> Change PHP version --> Select PHP-5.3.

2.Restore default configuration.

Open AMPPS control panel --> PHP --> click on Restore default Configuration.

3.Now run above commands.

Follow this guide:http://www.ampps.com/wiki/Category:FAQs#Accessing_Admin.2FEnduser_Panel_gives_a_Blank_Page

and all the other versions, reference just PHP in the directory structure, NOT 5.6
this fixes it.

#5

Yet another reason to check AMPPS OUT.

The Simplest Wordpress Backing up and restoring (on local host) I have ever seen.


He’s a bit slow with the delivery, but I think its worth the wait for the safety/safe space factor afterwards :slight_smile:
#6

Personally I would never use anything like this for a local testing environment setup. The security issues with the application(s) calling home would be too much of a concern for me not to mention the bloat installed by these done for you one click install systems. I don’t even use my webhosts variant of these one click installs.

I manually install Apache, Mysql and PHP which allows me to securely install and configure these to work how I would like. Many Youtube videos and websites that show you how to get every aspect setup manually. Yes it takes longer than one click installing but I know how everything works and where everything is located. Plus I am protected from tracking and having files transmitted to some online server somewhere, who knows if they access and collect private documents or system information. I know Apple does this, it is or was in their user agreement, I don’t need my databases or development projects sent to some server somewhere by a one click do it for you application(s). Not going to happen here.

#7

Valid points.
However, on my mac i run hands Off! and or little Snitch and am that anal that every app and each connection to each resource has to be cleared by myself.
Every connection (even Pingegrow gets this treatment)
AND I connect via a VPN that also shows connections - and data flows…

SO that point is covered.

And I guess from our reply that you have never actually tried this out at all? ie
I would never use anything like this… is this correct? just asking?

BUt for ease of access , speed and jsut the darn curisority of it , on a test box, to have access to so much stuff to play with,

… not even intrigued? CMS’s, MIcro BLogs, databases… so much!

If you were to attempt to install all that , just to check them out on your system… well you just would never bother to to explore them , it would take too long, just to explore them without actually using them,
in order to check them out.

Over 450 install scripts, truly wonderous!
I have NO IDEA why it isnt far more popular. It seem relatively unheard of in the local dev circles I frequent.

ANd as well as that you can just use it or running your local servers with none of that one click goodness.

the same as MAMP wamp, etc, with a little simple control panel,
WHich again… is not the way YOU do it :slight_smile: but that is why I’m asking if anyone does know much of this.
I have been using it and find it pretty awesome (and overwhelming with the number of choices with it )

This is after using MAMP /Pro for some years. (Not the most current verson atm)

It doesn’t tick any of your boxes, so that’s ok. Your way too is totally cool. Cheers for the feedback.
I used to do it that way too. I found it a bit dire.

SO, has anyone checked this out and actually USED It, or wants too ? TO compare notes.

just some… of the firewall treatment our beloved PineGrow gets, a few versions… The RED dots indicate its blocked.

SO You can imagine the hammering I give this other stuff :slight_smile:

#8

I tried “WampServer” (windows only) once many years ago, because I was curious about a bundled package. But I got difficulties running it and get it to work (Maybe I got a buggy version, don’t know).

Removed WampServer and installed everything manually (Apache/PHP/MySQL/PhpMyAdmin/Xdebug), and it worked right away. Since then I never tried a bundled app and use/configure it always manually. And I must say, it feels better using it this way than a “bundled” package for the reasons @Terry44 mentioned. That’s also the reason I never looked at a bundled package again and do I all myself manually, for better control and safety.


@schpengle From your screenshot I noticed that you are not running the latest/newest Beta version. maybe you missed it or didn’t noticed it yet. You can find v5.052 on Slack! Some “floating” issues are fxed with this new Beta!


#9

Oh cheers Marf, thanks no I am running 5.051 didnt see there was a newer one, will get it now.
I actually have about 8 versions of Pinegrow installed :slight_smile:
That was just part of a screen shot :smiley: with SOME of them.

I was running version 1.27 the past few days and was going to do a comparison with the latest versions, due to the fact that the Code Editor view USED TO ACT AS A SEPARATE WINDOW PANEL back in the day!
So pop ups etc used to do weird things like be behind it, or if you CTRL+TAB to change apps - you didnt! - you changed to the other window code view the first time as though it was a separate App etc.

I was going to send a screen shot comparing the advances in our fab web ids, compared to how it used to looked , viewing @randyrie 's recent dev work - but his page crashed 1.27!

SO I started to look into that, realised I was going down a rabbit hole…and…well, You now don’t have an interface comparison :slight_smile:

I will try and get into my GeekOrium today… my temple of geeky techie goodness, in my front room.
It has become cluttered but then I can get to my other monitors to better check out the latest beta, and might set up one of my linux laptops. I might even try and set up the standard LAMP stack manually again,
but to be honest…

Life is too short.

And I’m trying to put the fun back into all this stuff.
I find AMPPS …well, FUN!
:slight_smile:

For me! Its incredible I find.

And I can’t find ANYONE else on here who has even tried it!
wow.

Similar things yes, but not this and once you use this you see it is NO WHERE near similar.
IT Does so much that like Pinegrow it confuses me constantly !
…then realise I have to learn more.

SO, trying to make Learning Fun.

Manually configuring a MAMP stack and REMEMBERING what I did and constantly trying to update it
Come under professional not fun.

SO I get that, but I really do recommend someone installs and plays with it if they are/have become a little jaded with all this for the ease of usability, and sense of experimentation.

So maybe try it out?
and Just like Pinegrow, I really need to use it a lot more as I forget the UI’s and basic muscle memory so quick!

#10

I just had a simple problem with AMPPS and tried to resolve it via thier support ticket issue
and their forum.

Forget both of them.
the Forum Is AWEFUL TO USE!!! diabolical.

like it took days to successfully join.
dAYS.

first set up account never received acknowledgement email so couldn’t confirm… identity.
so schpengle is now forever lost in their system as, no reply for assistance.
had to set up another account.

reCaptcha

I NEVER WANT TO SEE ANOTHER ONE AGAIN.

so after FINALLY setting up an account, … you STILL have to use this! even though you have validated your email and your account.

THEN…you will have 6-10 OR MORE … reCaptchas… FOR EACH POST!
many with multi please click the new images … it can take up to 5 minutes or more to post a simple comment.

This lasted for 3 days.

Support Ticketing system.
no reply (3 days)

Forum
no reply 3 days

gave up… installed… reinstalled… worked out… its a simple thing!
so simple…

yeah so I still currently recommend giving it a go, but the support aint so good.
Just keeping you updated :slight_smile:

#11

No, it is not anything I am interested in. I don’t have time to play or check out every single framework or cms out there. I personally do not use most of what you are interested in playing with. I stick to the basic html, css, php, javascript and mysql for database and add features as much as possible via hand coded javascript and css. When that is not possible I use something like vue.js and sometimes jquery but today most things can be easily done with native javascript, even games if that is your thing.

I do not have any troubles with my local server setup, never had to refresh anything or reinstall. It just works.

I have used wamp, vertrigo years ago but last I looked vertrigo was a dead unsupported application and since I install and setup manually I do not have to use something like you do. I created my own apache / mysql control application and unless I need to upgrade php, which is just simply unzipping the php variant into a folder and making a couple changes to the php.ini file it just works.

Most of the libraries and frameworks are so full of bloat it almost is not worth using them. Sure you can do lots of things with one line of code but to get that one line of code to do what it does takes hundreds of lines of code. I just write 10 lines in raw native javascript and get the same effect. Makes for faster site loading and less resources being used. I don’t use anything that dictates a certain way of coding or site layout. If it can’t fit into the site or application I build without any structural changes needing to be done I will not use it. Codeignitor and similar frameworks are a no go for me, I have my own way of doing things and they tend to have their way of doing things which are not a match for me and simply get in the way.

I am glad you find your bundle of toys to play with useful for you. I just don’t have time for playing with everything out there.

#12

Nice set up you have :slight_smile: I like the idea of you having created your own little control app. Shiny.
And yes, this is indeed a fine bundle of toys :slight_smile:

I think it is also rather shiny (although I have to admit, the support sucked when I needed something simpel sorting which turned out to be Operator Error and alas, I was the Operator in question.
But I figured it out the long way around of course…

SO, thank you for your feedback young man :slight_smile:

Now, has anyone else used/heard of/ tried AMPPS?
If so, what do you think of it?