Pinegrow Community Support Forum

Undo and History not working

#1

I seem to be having some issues with cmd+z and also the history panel. I can’t seem to undo anything. Anybody else?

1 Like
#2

Yes same here.
Just installed the latest 4.3 and there is no history saved in the undo at at all.
and cmd+ z doesn’t seem to work either.

Mac OS X 10.13.3 High Sierra

I will tinker and explore

EDIT
mmm, after loading up the same project and then individual files in 4.2, the history and undo reappeared.

Then, everything seems ok again. created completely new site page from a template with Bootstrap template and it seems to be working. again.
odd

#3

same here, after creating a new page History and Undo are working normally. Go figure …

#4

I’m also experiencing problems with undo. I’m finding that Undo is very unreliable if you’re using Pinegrow to do text edits of the source code for both CSS and HTML. This is how I primarily use Pinegrow. The undo and redo is very erratic when you’re working in the code viewer. Steps are often not recorded so when I undo, it actaully jumps back five steps, but then when I try to redo, the history is no longer there so I can’t redo back to where I started and I lose work that I didn’t mean to undo. Worse yet, several times I’ve hit the undo repeatedly because it didn’t appear to do anything, but what it was actually doing was undoing other pages that I wasn’t currently viewing.

This is the one thing that’s keeping me from being completely in love with Pinegrow as my new Web editor.

2 Likes
#5

Yes, I have had that too I THINK i’m undoing the page Im working on, in the visual editor, but… I have the code view open for a different page…oops. which one does it undo. or same if I am viewing the css.
Also, what I have found is that once I actually DO an undo action… the list history of actions is saved for a bit , but If I do something like then save the page… thats it! all the undo’s dissapear from that point on …previous points still there.

Its interesting. I shall explore and try and figure out the patterns. Breakfast now though :slight_smile:

1 Like
#6

Schpengle, good idea on finding some patterns. Nobody’s going to be able to help us if we can’t identify some common threads for how our problems occur.

I’m using Pinegrow with a master page in a Pinegrow project. I’m finding that any edits I make in the metadata tags in the HTML <head> element are usually excluded from undo and redo behavior. If I try to undo something there, either nothing happens or something seems to be getting undone elsewhere… but I’m not entirely sure about that either.

When I hit undo and nothing seems to happen to the document in front of me, I start seeing the “*” askerisk character appear in the tabs to indicate a file was changed on other files that I’m not currently working on. I assume this to mean that those files were the receipients of my undo actions, but I’m not certain this is true. I do apppear to lose random chunks of work that I can’t explain. I just don’t know if it’s due to this undo problem or if Pinegrow has another issue that’s causing this.

#7

Ok, this is madness. I’m losing work in chunks and Pinegrow is causing what appears to be random changes. The undo key is completely unstable. It’s dangerous to use.

#8

I am also having this issue. My undo history is gone and the undo button does not work.

Pinegrow 4.3 Pro Windows 10

Do the developers look here? I haven’t seen any responses to this issue.

#9

@whitedragon101, yes they do, you only have to have a little search/look around.
its pretty actively discussed and they have posted their recognition of the problem.
ie,

it made for some colorful reading :slight_smile:

1 Like
#10

Just downloaded the new 4.5 update. Seems like new features have been added. But the “undo functionality” has still not been addressed. Take a look at this video: https://www.dropbox.com/s/h5mqzovm3hm607w/pinegrow-undo-function.mp4?dl=0

If you watch closely you will see that I first deleted 1 character “>”. Then I click on undo and nothing happens.

At a later part of the video I delete several words. When I click undo it undos this properly. Then i go back to deleting 1 character “>”, click undo and nothing happens.

I would appreciate it if someone from the Pinegrow team would respond in this forum regarding the “undo problem”.

#11

What I noticed is that often when I use the undo/redo function, I have to refresh the current page view with [ctrl] + [R] or the loop button on top to see the changes.

refresh.

Also, when I “redo”, it seems that I have to do it until the “nothing to redo” message appear.
This is far from perfect and I wish that the devs address this problem.

#12

There seem to have been 2 updates in fairly rapid succession which is cool, 4.4 and 4.5.

The 4.4 update seems to have added CtrlZ undo back in although it works a bit more randomly than every other CtrlZ I have used. e.g If you write a sentence and then miss spell a word and press CtrlZ you lose the whole sentence not just a char or word.

Still needs work but definitely better than nothing.

You seem to have no undo functionality in v4.5. I wonder if 4.5 broke the undo again. I think I will stay in 4.4 until I get confirmation as I don’t use bootstrap.

#13

Oddness abounds.
On a Mac, I can edit and use CMD+Z to undo, but , it is a little erratic.
I really mean to explore this.
but here you go.

an odd thing is how the cursor moves to inside the part and then , at the end, about 7 seconds before the end when Im faffing around, that is because PG is telling me nothing to Undo

WEll, there is :smiley:
Thats why that meta word is still there in tags. that should be able to undo and remove too, but, it isn’t.

#14

oh and please excuse the kitchen sounds. they thought that was the ideal item to start trying to smash all the plates up :slight_smile:

#15

and just keeping this bug alive, as I have been working in Pinegrow now, saving , making deleting, but, I stilll have NOTHING showing in the Pinegrow activity/undo tab.
Pinegrow 4.5 , Mac High SIerra

#16

I’m disappointed to say that Pinegrow 4.6 is still buggy as hell as far as the undo feature is concerned. I loaded a basic Foundation 6.4 starter template page and started typing out a few things in WYSIWYG mode. I changed my mind and hit undo a few times. It almost appears like it undoes and redoes in a random fashion. You lose data and cause your page to get corrupted when you use undo and redo.

#17

After a few months away from pinegrow, working on PHP, I returned this afternoon to discover a NEW VERSION 4.7!! Got all excited and installed it and tried the crtlZ (undo feature) which I complained about ages ago. Alas it is still as buggy as before :weary:

I don’t think they are going to fix it - just consider it a feature.

EVEN WORDSTAR (ON CP/M) HAD AN UNDO FEATURE!!
(^U)

1 Like
#18

@Raj

Thanks for the feedback.
Would you be kind enough to provide a few more details about your current issues and most important, because we are always looking for improvements, what you think could be a bulletproof undo system.

Note: you will have to take into consideration the fact the Pinegrow handle HTML and CSS, that you can have more than one document open at the same time (and so that you can create modifications on several different type of documents during the same session) and more …

Thanks!

#19

Hi,

PG 4.8 on a mac
Fresh start.
Opened a css file within a project.
Typed a few letters. (‘is undo working ?’)
undo.


It does’nt work, it says : ‘nothing to undo’.
The file itself knows it has been modified (it has * in da title).
same behavior with combined and separated history.

Can you give us some news about undo fixing ?
Its really buggy and its spooky to use it :wink:

Thanks :slight_smile:

1 Like
#20

Are you just opening a CSS stylesheet with no associated HTML page? That could be your problem. Not sure if Pinegrow keeps a history of edits unless there’s an actual website page open.