Pinegrow 3.0 Licensing

So I just saw that the upgrade is available. I installed 3.01 and it’s asking for a trial key to start instead of upgrading my 2.95x version. I have support for upgrades through 2018. A couple of other weird things is that when I sent the email to support for the trial key and entered it, closed the dialog. When I restart pinegrow it’s version 2.95x telling me there is an upgrade??

The diallog for the trial/buy now is also not displaying correctly within the defined box. Seems like the bottom half is being trimmed off a bit so the button to continue is below the modal dialog.

This is running on Windows 10, lenovo W530, Corei7 w/4 cores, 16G ram, SSD hard drive.



Hello Vince,

Please, contact the support with all the details (license and more).

I’ve resolved the problem. The activation dialog on windows is cut off on my computer so I couldn’t see the fields to input the email and serial number. On the mac it’s fine. I was able to activate both platforms.

Oops a’ Daisy! Maybe get a bigger monitor @vrooney?
(P.S. I used to get a similar issue with the Manage Libraries and Plugins option.

I could never see the subtle, skinny scroll bar on the right and there was a space at the bottom.
I felt rather relieved/humiliated when @rob suggested I… scroll down.

Nah it running on a 17 inch screen on a kick ass Lenovo Laptop
"workstation class" with Nvidia. They have an issue with the dialog
scaling on windows 10. It’s modal and won’t scroll. It’s a square situated in the middle of the screen with a border.

What’s strange is that the purchase/activation dialog displays correctly now that I have it activated. It’s nice and wide and fits everything. It seems to be the initial activation dialog displays as a square instead of a rectangle so it crops the dialog.

Hey I’m happy to have my hand on V3 finallly. :wink:

Hope all is well with you buddy.


1 Like

Pretty much so! Apart from the reality that is my life, but hey! lets not go there :slight_smile:
This virtual one is just as good, with less hiccups…KaBOOM!