Pinegrow will not open my shtml files

I use SSI on my pages so many have an shtml extension rather than html. I used to be able to get Pinegrow to open these files but after a recent update I just get a popup saying Pinegrow can’t edit them.
So I have to rename the file html, edit in Pinegrow, and rename to shtml.
Is there any easier way to do this?

I’m not sure why the recent update would have changed this, but you can allow for opening of shtml files in the settings.
Under the “Support” menu from the top bar select “Settings”.
Scroll down to “Internal Web Server & Proxy Settings”
Add “.shtml” to the input box for “File types editable in Pinegrow” - make sure to include the period before shtml

Save and then restart.

1 Like

Thanks so much. I really appreciate your help.