VS Code - can't get Pinegrow Live Sync extension to work [Fixed]

In VS Code 1.77.1 (2023-04-04) I have installed the Pinegrow extension per https://pinegrow.com/docs/master-pinegrow/using-external-code-editors/visual-studio-code/. However, I can’t get any live sync. Pinegrow only syncs from VS Code if I save the VS file. This operates the same way even without the extension.

Also, if I click my cursor somewhere in the VS Code file, Pinegrow doesn’t follow suit (also vice versa).

In the Pinegrow extension settings in VS Code, I have set the url to (the same as Pinegrow). (The original VS Code extension setting was http://localhost:40000). I have restarted both VS Code and Pinegrow but no luck.

Pinegrow 7.2, Windows 10

Don C.

1 Like

Hey Don, I can confirm the same issue on Windows 11 even though it works as expected in macOS. Apparently Windows does some silly stuff (surprise!) that is making this difficult for live sync to work properly. Matjaz is aware of the issue and I sent him a video of it happening to me a day or two ago.

1 Like

i got the same issue, just out of curiosity ill try the old PG release on a win8 machine

I had the same problem a little more than a month ago and I solved it by backing up a version in VS Code and that helped.

So I’m running the latest Pinegrow release and one version back of the Pinegrow extension in VS Code on my Windows 11 with no problems.

I hope this helps.

Just to be very clear, I didn’t changed my VS Code version, I changed the Pinegrow add-on version in VS Code.


Yes, backtracking the Pinegrow Live Sync extension in VS Code from version 0.0.8 to 0.0.7 worked for me.


I’m glad to hear that mate. :+1:

can i download the older version from somewhere or it’s something you have to have downloaded back then? of so, I don’t be gla dto have a copy of the older plugin if you could share it with me.

tytusie –

Assuming that you have already installed Pinegrow Live Sync –

  1. In VS Code access extensions
  2. Under “Update” select “Ignore updates”.
  3. Right click on the adjacent tool icon; then “Install another version …”; then 0.0.7
1 Like

great, i’ll do that tonight

Thank you, hope it ll work

I have the same issue with latest vs code extension. Downgrade solve for now!

1 Like

True story - i confirm, finally it works and it does sync live any changes you do in the code are reflected in the software.

The issues with the VS Code extension come from url mapping between Pinegrow and VS Code on Windows. There, URLs are represented slightly differently and then the extension doesn’t recognize that the document is open in Pinegrow.

I just updated the VS Code extension to 0.0.9 with improved fuzzy logic for mapping urls, that should ignore slight differences in URL formatting.

Also, Settings now have the Enable debug checkbox that when enabled, outputs information to the debug console. We can use this for troubleshooting any issues. There was also a bug that caused endless “File was saved in the external editor” messages in Pinegrow when the document was saved in VS Code.

Please try to update the extension to 0.0.9 and let me know if it works better now. If it doesn’t work, enable the Debug mode:

And then send me the output from the Developer Debug console:

Thanks! I hope we’ll finally get the extension to work correctly in all situations.


@dculp @tytusie @kalsson1 @vanheber I fixed some other issues in the last few days (thanks @adamslowe for testing it) and it appears to be working much better now. Please give the latest version 1.0.11 a try and let me know if it works.


Hey @matjaz !

I’ve had the opportunity to test the latest update now and it’s working great so far. Thank you for your work.


@matjaz I’m still only able to use v0.07, the newer versions don’t sync (Windows 10). I’ve sent several emails over the last 3 months but nobody is responding. I’ll send another email today as well.

@jonroc please provide debug information from v0.0.11, as described above in this topic.

Sorry about that. VS Code integration is an open issue that we are trying to improve, as evident from the many extension updates. The last update fixed the issue for many users. The debug info should help in troubleshooting your situation.

1 Like