Customize and Update Bootstrap Theme Not Working (Debian)

On debian clicking “Customize and Update Bootstrap Theme” creates the custom.scss file but does not properly link it to the current page. Also, the normal dialog that comes up in Windows and Mac telling you to create customizations in the custom.scss file instead of the theme itself does not appear. In addition to that, I have not figured out how to manually connect custom.scss to the file so that the interface works as expected (linking in the scss parials etc). How do I resolve this issue? Is there a missing library when installing in Debian? Another symptom is when you choose to edit a css file as an scss file, it creates the scss file but doesn’t link it into the active file. How do I resolve this problem?

Hi @siteleas,
Pinegrow only gets deep testing on Ubuntu, but maybe I can help. Are you able to manually link the CSS and SCSS files using the manage stylesheets dropdown? If you open the devtools, are there any errors thrown to the console? If you run Pinegrow from the command line do you get any errors? Finally, if you run ./PinegrowLibrary from the CLI do you get any errors?
My guess is that there is a problem with the core node-sass package, but it is supposed to provide support to Debian, at least on x64 arch.


@siteleas @RobM

I can confirm a glitch when you add a CSS then decide to create/use a SCSS source file (still the SCSS file is created and the next time you start the project, Pinegrow ask to associate it to the CSS file), but I have just tested the Customize Bootstrap 4 process with Ubuntu 20.04.2 LTS which is our test platform currently and it went fine. (see the following video)

More investigations in progress. (in progress: the issue is not only visible on Linux but on macOS as well and probably Win10)

Just a heads up. I am using lmde 4 (Debian 10.2 - Buster).

When I uninstall Pinegrow 5.991 and install 5.91 the feature works without issue. I am going through the different newer versions to see where the feature regression happens.

So, after installing one version at a time from 5.91 up, I have found out that the regression happens in version 5.981 (PRO Personal).

Here is the output when running ./PinegrowLibrary from the terminal:

[21350:21350:0208/] InitializeSandbox() called with multiple threads in process gpu-process.
(node:21360) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
(Use node --trace-deprecation ... to show where the warning was created)

When I open the chrome DevTools (F12) and I execute the command, the following appears in the console:

node exception Error: /lib/x86_64-linux-gnu/ version `GLIBC_2.29’ not found (required by /tmp/.io.nwjs.TUa3k4/node_modules/node-sass/vendor/linux-x64-83/binding.node)

I performed the following command:
sudo apt upgrade libc6

but that did not resolve the problem. The same error appears in the Chrome console.

This problem doesn’t happen on PinegrowLinux64.5.973

1 Like

I hope the PG Team have kept a seat warm for you in thier Debugging Lounge,
… with a coffee to go.

Well done.

1 Like

Thanks! Looks like my guess was correct about node-sass being the problem.

It’s strange to develop Pinegrow with a requirement that is going to break compatibility with a mainstream distro like Debian Buster (10). Evidently the indication is that libc6 will have to be built from source in order to be able to have glibc_2.29 as 2.28 is the latest version that is compatiable with Buster. I think that this creates a big problem for a number of users that prefer to use debian (less proprietary distro) rather that a big big ubuntu distro.

I have never built a library from source. Can anyone help me with step by step instructions on building GLIBC_2.29 from source on Debian 10 (Buster)? I would really like to have the latest version of Pinegrow to work with on my system. As I said the problem doesn’t happen in PinegrowLinux64.5.973, but several new features are missing in this older version.

Also, can anyone tell me how to get this bug to the Pinegrow team so that they can know to resolve this problem? I can’t be the only person using Pinegrow on Debian 10.

@siteleas We read you :slight_smile:
Thanks to your detailed feedback, we are going to check the situation in depth.

1 Like

Could you forsee any problem downloading and installing this deb?

If you need any help with testing or UI enhancement feedback / testing, please let me know

I tried downloading libc6_2.31-9_amd64.deb and installing that, but I get the following and don’t know how to overcome this problem:

sudo dpkg -i libc6_2.31-9_amd64.deb 
dpkg: regarding libc6_2.31-9_amd64.deb containing libc6:amd64:
 libc6:amd64 breaks locales (<< 2.31)
  locales (version 2.28-10) is present and installed.

dpkg: error processing archive libc6_2.31-9_amd64.deb (--install):
 installing libc6:amd64 would break locales, and
 deconfiguration is not permitted (--auto-deconfigure might help)
Errors were encountered while processing:

Not sure about resolving the errors. I just took a look and glibc 2.31.9 for debian has been migrated to testing as of mid-Jan. - it is in the unstable version as of beg. Jan., but I’m not sure how easy it is to get an image for it.