Font size in Code Editors

Can’t resize font in code editor.
Although I changed it to 18px in Settings, it reamins at 12px

1 Like

@millano572 can you provide more info please, not really enough for any of us to be able to help. Are you using a framework, if so which. Is it a particular element you are trying to resize the font in, etc. Maybe add a couple of screenshots.

I would also like to know if I’m doing this wrong and how to change the font size in the PineGrow code editors.
I select “Support -> Settings”
Change Font size in Code editors from 12px to 18px and click save.
Nothing changes. The font in the code editors is still really small.
Is this a bug or am I doing something wrong?

I experienced the same issue recently, and also found the problem!

This is a copy of my post from the Pinegrow Slack Channel:

:information_source: An update for the issue I had with the “font-size” not changing for the “code-editor”!
I studied the Pinegrow source code a bit, found the problem and fixed it !!!

For these 3 files at line 3760 :


.CodeMirror pre {
 font-family: 'Monaco', 'Menlo', 'Ubuntu Mono', 'Consolas', 'source-code-pro', monospace;
 line-height: 1.33;
 font-size: 12px;

Must be (without font-size declaration)

.CodeMirror pre {
 font-family: 'Monaco', 'Menlo', 'Ubuntu Mono', 'Consolas', 'source-code-pro', monospace;
 line-height: 1.33;

@matjaz Can you fix this in the Pinegrow source code, and remove that “font-size” declaration…?? :see_no_evil:


Thanks Marf. That worked perfectly. With that font-size: rule removed, changing the settings inside Pinegrow works just as expected. :slight_smile:

1 Like

Thanks @Marf, I did the change in the code.


Godlike Status there @Marf mate… :wink:

I can see the files on Mac, but not on Linux. The Linux installation seems to have everything bundled somewhere, or am I missing something?

@matjaz: Can you push an update of Pinegrow with this fix? On those fancy new 4k whatnot screens the editor font is the tiniest of tiny fonts!

This fix is already in Pinegrow 5.0. It doesn’t work for you?

Yesterday it didn’t work for me. Today it does. How bizarre.
I’m quite sure I was on 5.0 and I did put ‘px’ in the font size - I can’t think of anything else I could have done wrong.
Sorry for the confusion.