Pinegrow Community Support Forum

Inline elements should not be given a new line with code reformatting

Inline elements like <strong> should never be given a newline when Pinegrow reformats code, as this introduces unwanted whitespace into the text.

You can disable Pinegrow’s HTML auto-formatting in the settings menu under Support > Settings

Yes, I ended up doing that. Still, it’s a bug as I see it that the devs might want to fix.

What are you doing when this happens. I tried dragging the strong element both on to the page and into the tree, and in neither case did it create a new line in the code. I even saved the page and reopened it, and the <strong> element stayed in the same place I put it.

I’m seeing it within <li> list items. (It doesn’t seem to happen within a <p>.)