Keep multiple workspace windows always on top in Windows

I did a quick search but didn’t find any similar topics. I use Pinegrow extensively with a 3 monitor setup in Windows 10. I normally use a saved 2-screen workspace view but often have different components of the UI full-screen on all 3 monitors at any given time. However, whenever I open any file or browser or app on any of the monitors, the UI windows on both of the OTHER monitors auto-minimize and the workspace view resets. This is highly annoying as I normally have multiple windows open underneath Pinegrow and Pinegrow usually ends up on the bottom of all the other apps. I then have to close all my other windows, maximize both Pinegrow monitor views again and resize all of the different components EVERY time I open another file or application. I have tried using Windows apps such as “Always on Top” and also set a hotkey shortcut which works with other programs but not Pinegrow for some reason.

I also have the workspace config saved in Pinegrow, but Pinegrow always opens minimized so I have to reconfigure and maximize the workspace every time I open the program as well.

Am I missing a simple setting somewhere or is there another option? Is there an option at least for Pinegrow to remember the maximized two-window workspace config? I absolutely love Pinegrow and can’t imagine replacing it, but this has become such an annoyance that I am seriously considering switching to something else. Thanks!

Tracking here - Is there a way to keep the pinegrow multiple screen windows maximized?

Wow, thanks for the link and the quick response!

Seems as if I’m not alone. Like the other thread, I often have to reconfigure the workspace 50-100+ times and I’ve just about reached the point where I need to switch to something else. I really hope this is addressed.

Hi @daddiofaddio,
I know @Akayy brought this up in the other thread, but what you are describing doesn’t seem to be what other are describing and does not seem normal. There is currently the issue of Pinegrow floating windows “hiding” when Pinegrow looses focus. I believe that this is a problem with an update to NWJS, not Pinegrow per se. However, your workspace should always open how you left it and not change after loss/restoration of focus. Can you pull a support ticket for this, please? (email: support@pinegrow.com) Trouble-shooting might be a little difficult since this seems to be project independant. Either installation or interfering additional program? Make sure to give details about your installation - old Windows install and then new 64-bit?
Thanks and sorry for your problems,
Bob