[PG 5.992] CSS Grid Edit- cannot resize visually

Hi - I am trying to follow the tutorial course on Learn CSS Grid with Pinegrow thinking it would get me up to speed on PG’s functionality. I got stuck basically at video 3 as the drag/drop functionality as demonstrated at 3:03 in the video https://youtu.be/PZushJSzdXc?t=183 does not work.

I have applied grid to body, I am working on the header element itself. The handles [A] do show. At first I could not drag the handles at all, but clicking on/off on the visual helper and/or clicking on the header element in the tree made them at least draggable. But they do not seem to ‘stick’ and/or ‘snap’ on any of the existing columns. Quite frustrating. I checked the forums for other bug reports and I see others may have experienced similar problems. Any advise on this? I am just returning to PG to check out its current capabilities and not sure what to think now.

Hi @syllie,
Sorry you are having difficulties. I’ll look into your exact problem, but in the meantime there is also an updated version of this tutorial. Summer Nights 2 – Creating a CSS Grid layout in Pinegrow | Pinegrow Web Editor
Maybe it has some pointers to help you around your stumbling block.
Can you let me know what OS you are using, please?

Hi @RobM - thanks for looking at my issue. I have just spent time on the updated version of the tutorial and it was just as frustrating. I thought to try and screengrab it and of course just after that ‘it suddenly worked’ (on the newer project) but it still failed on my original attempt. No matter what I try the drag and snap in the visual editor does not work.

You can see that first it will not switch away from automatic mode at all. Clicking the element directly in the tree does that though. Then dragging the box works, but it will just snap back to its original position. I have restarted the app but to no avail.

Screen grab: Recordit: Record screencasts fast & free! with GIF Support!

Details taken from my OS:

Edition Windows 10 Pro
Version 20H2
Installed on ‎13/‎10/‎2020
OS build 19042.928
Experience Windows Feature Experience Pack 120.2212.551.0

So I just gave a try with the 20H2 version without encountering any difficulties. Do you have any third party plugins installed? I wanted to show you a quick video, but I need a .net update that doesn’t want to install to do a capture.
The only thing that I can think is that if you don’t have any 3rd party plugins that either another application is interfering, or something went wrong with your Pinegrow install (did any antiviral quarantine a file?). Can you perhaps open the DevTools (right-click on the Pinegrow logo and select “Inspect”) and see if there are any errors in the console either at Pinegrow startup or when you try and resize an item?

@RobM Thank you for looking at this anyways Bob! I do not know what caused this inconsistent behaviour. I contacted support yesterday too as my TW addon would not activate - and I also reinstalled Pinegrow itself. That got sorted but may be yet another indicator something was not quite right with the PG install. This morning I restarted everything (system, local dev server, PG) and kept all other applications closed. And it worked.

TLDR; Behaviour was reproducible but went away after reinstall PG, reactivation PG, restart of system.

1 Like

@RobM There is definitely something not working right with the grid functionality. I decided to give this tutorial another go and it fails again on the ‘drag’ to reposition grid. As you suggested, I had a look under the hood and it is clear that the supporting script fails as a variable returns null. Screenies attached.

At any rate, looks like PG is still not quite there yet. I will do what I do for a few years now - and wait for a next update to re-evaluate.

Hi @syllie,
Sorry to hear about your continued problems. Would you mind sending your project to support@pinegrow.com? I’m not sure it will show much, but I have been unable to replicate the error you are getting. Maybe some light will be shown on the problem if we look at the project.
Second thought. Did you start the tutorial from scratch, or pick up from where it gave the error last time?
Again, sorry for all of the problems.

@RobM Hi Bob, thanks for returning to this post. I just zipped the project and sent it to the support email address. The project was started from scratch, but is the same project I tripped on last time.