Pinegrow WP Theme Export - Sides of Pages cut off + Questions

I am working on the development of a Clash of Clans related WordPress theme and with support of Supercell, we did this according to there design.

I have used Pinegrow WP for the development of HTML to WP but when importing the website the design is cut of on both sides and as soon as I click the homepage it opens up the .html file instead of which sizes properly.

The image below shows the issue!

The issue page

On the links down below you can find out what it should look like!

On top of that my main question for this website is that its a blogging based website so which of the 2 pages would become home.php and which would become index.php

As an example of that, I have the 2 pages down below.

For me this would be the first page people land on: which I think is home.php right? (I am totally new to creating themes with Pinegrow so please help me there)

I think needs to become home.php right?

Then my last question now I am busy is related to the topics you see on the blog page as I am curious if there is a way in Pinegrow that can help me set these up as the bar for new Categories.

Plus can I make the blog page keep its way of clicking in the bottom to go to page 2 and have a certain amount of blog posts per page instead of infinite scrolling?

Hi @Roasiac. Sorry if I miss I’m misunderstanding you question, you can select the page you want as your home page in the Wordpress dashboard under Settings > Reading > Front page display > A static page (select below) > select the page you want as your homepage.

Hey Rob,

Thanks for your response. This is not a page its the raw code that was exported through Pinegrow and uploaded to WordPress the outcome of the website was that both sides of the website where cut of for 50% and if you clicked the home page it would switch to the .html version of the website but this file was not available in the Theme and due to that I have no clue how that is even possible.

I would love to be able to fix this as a website with 50% of its left side and 50% of its right side missing does not work for me and visitors of the website.

Hi. If you’ve uploaded a html version of the index page it is being selected as the default page to display when someone visits your website. The default order of index file names our particular servers look through is index.htm, index.html, indexphp, and finally default.htm. Make a back up of the index.html page then delete it from the server. This should leave the wordpress index.php file as the only file called “index” in the home folder of your website. Once this has been done it should no longer display index.html instead it will correctly display the contents of index.php