Browser sync out again

After installing PG 6.1, my Open pg in Browser quit working. I did lots of Terminal runs. But what seems to have worked was unchecking PG’s “Use BrowserSync.” Open pg in Browser gave me

I can open my PG file index.html in VScode and click the GoLive extension. PG files show up fine on

Help clarify this for me please?

Hi @kat,
So VS Live Server will spin up its own server and look for a free port. You local host address seems to be, which is typical. Pinegrow grabbed port 40000, while VSCode grabbed 5500.

When you start browser-sync it should give you a message - the first line should tell you what it is proxying. It should match what the browser bar says if you open a Pinegrow page with BrowserSync turned off - so

Next there will be a table of access URLs. The top one is the local access for your web pages - probably http://localhost:3000. Might be different depending on BrowserSync set-up. That is where your live previews should show-up.

Where you might be having problems is the BrowserSync settings in Pinegrow. Under the Topbar eye icon the last menu item is the settings. the URL in that setting must match what BrowserSync gave as the Local URL.

Hope this helps,

1 Like

BrowserSync settings in Pinegrow: http://localhost:3000

But currently my PG live servers are working without checking BrowserSync.

Nice fixes and enhancements in 6.1. Think I’ll get to skip dragging files into a new project.