Pinegrow Community Support Forum

Install Pinegrow on Linux (+ Atom)


#1

I am a Linux (Mint 18.1) user and I decided to try out Pinegrow. I am mostly doing development on NWJS apps at the moment.

I was fuzzy about how to install Pinegrow, but being familiar with this sort of program I knew that they were fairly simple to make work. So I just downloaded PinegrowLinux64.2.951.zip and unzipped it into a temporary folder. I found the files that I expected, and just clicked on “Pinegrow Web Designer” and everything seemed to work.

After looking the package over I decided that it seemed to offer me good value so I purchased the Pinegrow PRO + WP Personal version. I moved the installation folder to /user/home/bin/pinegrow. Since everything worked correctly from the command line, I thought I would create a desktop and menu ‘launcher’ (oldskool, I know…). But I don’t see a useful icon/png/svg. No biggie, I can just use anything. But it would be nice.

Then I thought It would be interesting to try out the Pineview + Atom interconnect. I try to follow the instructions in the provided document, but Atom gives me an error. I find the posting “Problem with Pinegrow/Atom integration” from Andy and the fix he found.

My question is does it matter how or where I install this on my system, are there likely any gotchas related to this location and activation of other features, and do you have a small svg or png Icon available.

Dave


Place PineGrow icon in Ubuntu Launcher
Installing Pinegrow in Ubuntu 18.04?
#2

Hey Dave, I’m running Pinegrow Pro on LInux and at various times I’ve kept different versions located across different locations, sd card and local disk, so no I don’t believe it matters where you run the software from.

Ugly on the outside, beautiful on the inside.


#3

Jack,

Thanks, I just wanted to be sure before I dug myself into a hole. This seems generally true with NWJS and probably electron-based apps.

Dave


#4

Grab the image from Pinegrow’s Twitter Profile Image, its the same as the Pinegrow App Icon.

Then resize as needed.


#5

@Pinegrow_User,

Thanks! That will work…

Dave


#6

No worries. Good to see another Linux user. I always recommend Linux Mint to anyone switching from windows, I’ve an old desktop upstairs, been running various Linux Mint installtions for a decade now!

I was going to say I’ve never manually installed any software in user/bin and I don’t believe its recommended but I can’t see this being a problem.


#7

Gradually moving over to Linux Mint for most uses and what a joy after the various Windows 10 ‘upgrades’ I’ve endured over the last two years.

However… I can run Pinegrow on something like Zorin 12 just fine, no problems at all. But on the latest Mint 19, or straight Ubuntu, I’m having no luck whatsoever. I’ve run the recommended terminal app get but no difference. What might I be missing?


#8

hi, once you download Pinegrow, extract the zip and drag and drop the PinegrowLibrary into terminal and press enter. all should be OK in Linux Mint 19. let me know if this option works.


#9

Yes, that actually works - thanks!

Surely there’s a less clunky way of achieving that directly though. In Zorin I just double click the Pinegrow.desktop file and the program opens up. Why this workaround in Mint/Ubuntu? I’ve obviously missed something somewhere I’m sure.


#10

up to Pinegrow 5 , double clicking the Pinegrow.desktop worked for me as well, but since version 5 something changed I guess. but the most important part is that this workaround is functional, all settings are preserved and you don’t have to start with a clean state each time you start the app.


#11

This post answers the issue - you need to edit the exec path in the Pinegrow.desktop file:-

https://forum.pinegrow.com/t/place-pinegrow-icon-in-ubuntu-launcher/2578/4