Pinegrow Community Support Forum

Linux version not working - Solved


#1

When i “install” pinegrow as written on the linux info page unfortunately i am unable to run it.
When i double click the Pinegrow.desktop file, Pinegrow appears in my taskbar for a few seconds, then it closes itself.
when i execute the PinegrowLibrary in the Terminal, i get

./PinegrowLibrary: error while loading shared libraries: libnw.so: cannot open shared object file: No such file or directory

is there anything i can do to change this?

(Kubuntu 18)


#2

hi Sariel, I had very similar issue with Pinegrow 4 on Linux Mint and I managed to fix it with the permissions, marked them all as executable. I had different problem when Pinegrow 5 came out, the Pinegrow.desktop didn’t execute even with all permissions granted, so I managed to get it working with dragging the Pinegrow.library on to Terminal and hit enter. this is the only working option for me when using PG 5 and Linux Mint 19.1

let me know if this 2nd option works for you.


#3

hi @zedbuza,
thank you for your reply! unfortunately this doesn’t change anything for me.
so … any other ideas i could try?
thanks!
sariel


#4

is this the first time you use PG on linux? and which PG version? give me more details so I can try to find a solution


#5

@zedbuza yes, it’s the first time. i’ve used it on w10 before.
i have tested it in different locations, in /opt/… as well as my desktop. it’s the version for Linux 64 5.0


#6

hi Sariel, in the Pinegrow downloaded folder, can you check if you have a folder called lib and inside it a file named libnw.so ?


#7

WOW, i’m amazed how stupid i am!

@zedbuza thanks for the hint. somehow the folder structure was not preserved when the archive got extracted. there was a lib folder and it was empty. all its files were located in the main folder. same with all the other folders.

thank you for your help, everything runs fine now!


#8

glad it worked out, just please mark the title of your original post as SOLVED, it might help other Linux users as well.

best regards and easy coding


#9

Hi Zedbuza,

Draging the library to the terminal window worked perfectly.

Thank you for this solution.

Regards,

Ducktape


#10

This Q&A answers the Pinegrow.desktop issue - you need to edit the path in the file:-

https://forum.pinegrow.com/t/place-pinegrow-icon-in-ubuntu-launcher/2578/4